All plugins stopped working in Chrome

Good idea.
I got TM Beta going, and blacklisted TM from
Installed WKOpen Framework, WKOF Additional Filters, Double-Check and Heatmap.

WKD-C isn’t showing, and WKHM isn’t appearing on the WK dashboard.
@m0r1 are you on Chrome? What userscripts?

1 Like

Im on chrome and I think all(most?) of my scripts are working,

heatmap/leaderboard are showing up as intended

It won’t on the dashboard. Double Check doesn’t URL match with that.
After the update I regularly get no scripts running - TM doesn’t even list any (enabled or disabled).
Clicking “Create New Script” and then opening the “Installed scripts” in the TM dashboard reminds TM/Chrome that there are in fact scripts, and a refresh then suddenly gives me the scripts back.
Would love to know a perma-solution, because it’s a pain and seems unpredictable at the moment.

(before and after dashboard open and refresh =>)

Having the same issue, too. I need to keep refreshing pages for the scripts to load and work. Really unfortunate…
Gonna follow the thread in case anyone finds a solution.

Ive been having this issue for months. I don’t know when exactly it started, but about 50% of the time tampermonkey just doesn’t load scripts onto the page. I have not figure out the cause yet.

I also had this issue a while ago. I fixed it by disabling (not removing) the tamper monkey extension in my browser, restarting the browser, and then re-enabling it. It seems to be this issue:


Tried your idea of cycling TM on/off in Chrome>Extensions with a full restart of Chrome. Nothing good yet.
In your understanding is it a Tampermonkey issue?

Thanks for posting before/after. Once the scripts load for you do they run properly?
If I understand, I think I’m seeing them loaded but not running.

After trying @gijsc1 's suggestions (cycling TM off/on in Chrome>Extns) I have this slew of errors in the Chrome F12 Console:

I’ve noticed this happening while on the forum lately, like sometimes tampermonkey works, sometimes it doesn’t. Sometimes a hard refresh fixes it (ctrl + shift + r), sometimes it doesn’t. Sometimes opening forum in a new tab works, sometimes it doesn’t :woman_shrugging:

For me it looks like this, like I don't have any scripts installed when I do in fact use six userscripts.



1 Like

Here’s what worked for me (so far):
Disable TM Extension via Chrome>Extensions
Install TM Beta
Add WKOF, WKOFAF, Heatmap, Double-Check plugins
Disable TM Beta in Chrome>Extns
Close All Chrome Windows
Windows Task Mgr>Stop all Chrome processes (no idea if this helped, but I did it)
Restart Chrome
Enable TM Beta in Chrome>Extns
Refresh WK tab

Timeline, Double-Check and Heatmap all working.
So I guess it’s a TM/Chrome issue and the difference between TM and TM Beta is enough to solve it.

Edit: still getting all those errors in Console and more, but none seem to break it yet

I just swapped to violentmonkey on my chromium browser, and the problem is solved. Looks like current stable tampermonkey has the issue.

You can export to zip in Tampermoney, and import that into violentmonkey also, if you have many scripts and don’t want to re-add them all manually.


@Mojibaked Oh, that’s a good solution I didn’t know was available. Thank you!

I am not sure. I was just frustrated that my userscripts were only working half of the time, and after some googling I found the above issue on github. It looked similar to both my issue and what some of the people are describing here, and it solved the problem for me. But “my userscripts only work some of the time” is such a vague problem that it might not be the same thing at all.

1 Like

I had found the same bugreport, but disabling/enabling TM with browser restart (in various combinations) did not fix it for me. There are intermittent page loads where Chrome/TM simply don’t recognize there are scripts available. I also had no idea if it’s Chrome or TM - both updated at the same time for me.
@Redglare describes the exact issue I also have. Sometimes they load, sometimes they don’t. New browser tab or entire new browser doesn’t seem to influence when it loads and when it doesn’t.

Yes. Once Chrome/TM recognize there are scripts, everything loads fine.
Yesterday I loaded the dashboard fine, went into reviews and had no scripts available when reviewing. But when the dashboard loaded afterwards, everything was fine again. There seems to be no logical condition - which kind of makes me suspect a timing issue.

But if ViolentMonkey is a possible solution, I may just try to switch to that.

That does look like a different problem - the fact that indexedDB doesn’t open (not even logged as error) would be a problem for scripts later on (several scripts rely on it). Also good to hear that TM Beta fixes it for you. So I have several options to try out now.


Hmm. I’ve been off WK for a month, and I come back to Anime Sentences and SRS indicator being broken. The fixes were easy since people were already on it, but it has got me thinking about how much I depend on these scripts. Whether it be a WK update, TM breaking, Manifest V3, etc, I do think that it isn’t a good business model to develop an API for your users, and then take your hands off the keyboard, “alright, now you guys can deal with it!”.

Take Obsidian, a popular note taking app. Users develop plugins for it, but the developers integrate popular plugins into the main application. Has WK ever done that?

Whatever the answer is, these problems have made me want to be done with WK ASAP. I don’t want to be dependent on a website that has the potential to become unusable at a moment’s notice.

1 Like

Seems to have worked for me – huge thanks!

Update: The bug is back again and now disabling tampermonkey, restarting the browser and enabling tampermonkey again doesn’t seem to work…

moving here from TamperMonkey update crash to not duplicate the threads for this, my scripts did load, but only about half of the time - this goes for both the dashboard and the review page, hitting f5 few times worked as workaround, but it was very annoying.

i can confirm that i was getting the same error gijsc1 mentioned and linked “Uncaught pagejs missing”, nothing mentioned here nor in the github thread worked as a workaround besides exporting my scripts from tampermonkey, installing violentmonkey and importing scripts there (took like 20sec, its not as bad as it sounds! idk why i tried that one as a last resort haha). No problem with violentmonkey so far.

Thanks @Mojibaked for advice about violentmonkey and @gijsc1 for finding the error on github and linking this thread :slight_smile:

Mojibaked, thank you so much. This advice solved my issue in less than 3 minutes!

I followed @Mojibaked 's advice and WK on Chrome still appears grayed out like this. Not sure what’s going on :thinking:

I had the “users scripts don’t work half the time, so F5 F5 F5” problem too.

Advice I found elsewhere in the github issues discussion about this actually blames Chrome’s pipeline and some kind of filtering ordering when using tampermonkey, where plugins get applied in the wrong order as a web page is processed. The fix was to DISABLE tampermonkey itself (the global chome extension disable option, NOT by disabling scripts inside tampermonkey), then completely exit chrome, restarting it. Then enable tampermonkey again. After doing that, the “application order” is correct and the tampermonket user scripts work again. This takes 10 seconds and you don’t need to copy scripts or anything.

Uninstalling Tampermonkey and installing violetmonkey works not because violetmonkey is “fixed” but because installation changes the order just like a restart. So no need to change to violetmonkey!