Wanikani Reorder Ultimate [old version, not working]


#807

I just did and it seems to have fixed the problem! :smiley:
Sorry I only saw your post just now (timezones), but whatever you changed seems to have done the trick. I no longer have issues with the review session freezing. Thank you so much!!

By the way, I didn’t mean to put you on the stand like that or anything, I just noticed that both of these scripts didn’t seem to work at all with each other and wanted to point that out in case someone ran into the same problem. :slight_smile:


#808

Inspired by this, I switched the Ultimate Reorder script from Meaning-then-Reading to Reading-then-Meaning today, but whenever the reading comes first, it is not accepted by WK… The input field shakes but the word neither gets accepted nor rejected. Meaning-then-Reading works fine, though… I even set it to Random mode, and whenever the meaning came first, both would be accepted, but when the reading came first, it would be rejected. :thinking:
Did anybody else come across this strange behaviour?

EDIT: By accident I discovered that this is caused by the Katakana Madness script… The problem went away when I disabled it. Also, the issue only seems to appear for vocab, not for kanji.


#809

Got this when I finished my reviews just now:

TypeError: Cannot read property ‘rad’ of undefined
TypeError: Cannot read property ‘rad’ of undefined at Object.updateVisual (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=341d4f8d-7186-4bc7-9264-9c61cf3678cc:179:21) at Object.apply (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=341d4f8d-7186-4bc7-9264-9c61cf3678cc:269:29) at Object.create (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=341d4f8d-7186-4bc7-9264-9c61cf3678cc:277:30) at Object.init (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=341d4f8d-7186-4bc7-9264-9c61cf3678cc:237:26) at eval (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?id=341d4f8d-7186-4bc7-9264-9c61cf3678cc:740:15) at

Logs:
WKU Init()
Applying UID levels

I’m running:

Chrome 59
Tampermonkey 4.7.54
Wanikani Open Framework 1.0.36
Wanikani Reorder Ultimate 2 2.2.4
WaniKani Real Numbers 6
Wanikani Lightning Mode 1.0.9
Wanikani Override 1.1.3


#810

[…editing]
[…nevermind, tablet battery dying]


#811

Seems broken. I have the script activated and only one level to review but I still get a random order: it doesn’t respect the radical -> kanji -> vocabulary.

Version used: 2.2.4.


#812

Have you clicked on the right hand side of the scale and have the box “Sort Types” ticked like so? Only that will make the ordering work.


#813

I had the “sort types” checked.

I did not have the scale changed though. I don’t understand the point of those scales when the checkboxes are already checked. What would be the meaning of all combinations of checked/unchecked and scale in one direction or another? Doesn’t seem very intuitive to me.


#814

It hasn’t been working for me lately. I tried re adding it and no luck. This is what it says to me:

WKU::Please Wait::Currently updating UID list… 100%


#815

If it mentions “updating UID list”, you don’t have the right version.
https://greasyfork.org/en/scripts/19088-wanikani-reorder-ultimate-2


#816

They specify the sort priority: reading vs meaning (left scale) and level vs type (right scale).
The checkboxes just determine whether type and level are sorted at all.


#817


#819

First post should be updated. First time you use it, you expect that just checking the correct boxes would work, especially since there is no documentation regarding the scales.


#820

Fixed my issue, Wanikani Niai similar kanji is conflicting and breaking everything so I’ve just disabled it.


#821

Hello, i just instal this… can someone help me out to make it work. Thanks :slight_smile:

This is what i get “WKU::Please Wait::Currently updating UID list… 100%”

Also install the Open framework…

Working now…

But i cant see the left options. #1


#822

Strange. I have my latest windows 10 and both WaniKani Niai Similar Kanji and Reorder Ultimate 2 worked just fine.


#823

You probably got the wrong version (happened to me as well :sweat_smile: ) the first link under “Where do I get is?” is actually an old version (2.1.0), the current version is the second link (v2.2.4) I think this one should be right:

https://greasyfork.org/en/scripts/19088-wanikani-reorder-ultimate-2


#824

Dude you saved me… The original link was not working and I was having a meltdown since I cant do my reviews without properly reordering them lol. Why is this link not at the top?!


#825


#826

A pointer to a pointer

that’s elegant :ok_hand:


#827

Flashbacks to

https://community.wanikani.com/t/how-do-you-search-community-forums/25129