Wanikani Reorder Ultimate [old version, not working]

What are your sort criteria? Any errors on the javascript console? (Press F12 and click on the Console tab).

There’s no error in the console. My sort criteria is Radical > Kanji > Vocab. I’ve tried all manner of orders and it’s just completely random when I hit force-reorder.

Which OS, browser, and browser version? Can you post a screenshot of your settings?

It seems to be working after I clicked the right side of the right balancing image so the right plate was weighted down. Didn’t realize that was still a functional part of it, didn’t recall having to do it before but probably did. I would imagine that’s the default functionality most people would want it to be when installing such a script! Cheers

1 Like

Guys, please help. Can’t get this to work for the life of me.

I’m using Firefox 57.0b14 and I made sure there were no duplicated extensions in the browser. But I keep getting the “jquery is not defined” error. I’ll provide more information if needed- for now I just have this info from the console box.

Script error:
ReferenceError
columnNumber: 2
fileName: "resource://gre/modules/ExtensionContent.jsm"
lineNumber: 375
message: "jQuery is not defined"
stack: "userScript@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:375:2\nscopeWrapper@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:1078:9\n@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:361:17\n"
proto: Object { stack: “”, … }
Wanikani%20Reorder%20Ultimate%202:1080:23
Loading failed for the with source “https://cdn.wanikani.com/assets/v03/review/application-a9d56fe7838575d6e64bf494c077af35b542a299fc31c1aebc9f33104b08df8b.js”.
session:9
Script error:
ReferenceError
columnNumber: 2
fileName: "resource://gre/modules/ExtensionContent.jsm"
lineNumber: 375
message: "jQuery is not defined"
stack: "userScript@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:375:2\nscopeWrapper@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:1078:9\n@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:361:17\n"
proto: Object { stack: “”, … }

Do you have Tampermonkey or Greasemonkey installed? If not, uninstall this script first, then install Tampermonkey or Greasemonkey, then install this script.

Yeah, I already had Greasemonkey before installing it and everything, so I’m totally stumped.

I’m not sure where the blue link above is being referenced from, but it’s not a valid link. Normally, jquery is wrapped up inside a link that looks similar to that, and is loaded by WK itself. Reorder requires jquery to be already loaded before it runs.

Exactly, it’s really weird and I can’t figure it out.

Just checked the console again and now it has this:

Script error:
ReferenceError
columnNumber: 2
fileName: "resource://gre/modules/ExtensionContent.jsm"
lineNumber: 375
message: "jQuery is not defined"
stack: "userScript@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:375:2\nscopeWrapper@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:1078:9\n@user-script:https%3A//www.wanikani.com/Wanikani%20Reorder%20Ultimate%202:361:17\n"
proto: Object { stack: “”, … }

If we can’t find out what it is then maybe I can try chrome as see if it runs on there.

I just remembered, Firefox was going to discontinue ‘legacy’ plugins in November 2017. Read [this] blog post, and then check your Greasemonkey version. I don’t know if that’s an issue, but it’s worth checking.

Okay, I’m gonna do some investigating and might be back. Thanks for your help!

By the way, Tampermonkey is available for Firefox. That’s another thing you could try.

1 Like

Awesome, hopefully that’ll do it.

I would suggest VoilentMonkey fir Firefox it has much better UI and is more accessible. Plus it is available for Android too.

1 Like

Installed Violentmonkey and it’s working now. So I guess Greasemonkey was the problem.

Finally I can reorder 1x1, wooo!

Thank you all for the help!

1 Like

Good to know! I haven’t used it. I see it’s available for Chrome, too, so I may investigate.

1 Like

It seems like all my userscripts broke because of the firefox/greasemonkey update today. Definitely will have to try ViolentMonkey because I need, at the very least, my Override script >_>

1 Like

Yeah Violentmonkey fixed it right away for me, haha. These scripts make reviewing so much more convenient.

Where is the ui located for this script?
Can’t seem to find it anywhere on my dashboard, i even inspected the page but no luck :confused:

It’s in the review/lesson session