Wanikani Reorder Ultimate [old version, not working]


^^^ It’s a known issue due to WK changes. See the discussion above.


Fix it @rfindley!! If you can’t do it, no one can!


Heh… if it was trivial, I’d have fixed it already :-). I’m trying not to take on too much tangential stuff (and somewhat failing :-/ ). Paid work needs to take priority sometimes :grin:


Could probably easily route everything through the rad/kan/voc instead of id. Would probably be better storing it as an object somewhere in the script since what is already used takes up a lot of space in localstorage.

Just do something like levels[text]


FYI, I’m putting together a framework that uses indexeddb instead of localStorage, since indexeddb allows much more storage and provides indexed lookup. The framework will cache all WK data, including the new IDs, and will have its own simple API for pulling data from cache.


And when will this be done O Magical One?
(I jest, I jest, mostly. :neutral_face:)


I’ll take a look at doing this tonight. That might just be a simple enough fix.


It’s my active side project. I need to use indexeddb for some other stuff, so it’s a dual-purpose project :slight_smile:


:point_right: [ v2.1.1 ] - Temporary fix after Wanikani changes (UID errors) :point_left:

xMunch pointed out the easiest way to fix this temporarily, so here’s a quick attempt at implementing it.
No guarantees that it works 100%, but during the little testing that I was able to do, it seemed to work properly.

Wanikani reorder ultimate 2 down
Wanikani scripts not working

I tried it on and it worked perfectly for lessons. But I’m getting this error during reviews.


What browser are you using?


Firefox Quantum (Developer Edition 57).


Hmm… I wasn’t able to duplicate your error, though I don’t have the developer edition of Firefox. Could you check the Javascript console? Maybe the errors there are more useful.


ok. I’ll try other a new browser profile too. Maybe an issue due to some extension…


Tested with fresh profile. No error. Maybe something is wrong with my original profile.


Interesting! Let me know if you figure it out.


i’ll try to disable all extensions and try to enable them one by one.


issue was created by this addon. Also found out that they were collecting usage information without consent. Removed it.


Love you as always. さすがですね!


So, in this fixed version, I don’t have errors, but it doesn’t seem to be ordering them as defined… Do I have to clear out my reviews before it starts being able to work?

What do you want now? (Request extensions here)