[Userscript]: WaniKani Ultimate Timeline


#544

I just updated my Firefox to 60.0, and am using TamperMonkey. It’s working fine here :thinking:

Ultimate Timeline won’t appear on the Dashboard until the web page is fully loaded. Right now where I am located, Wanikani seems to be loading very slowly. Try confirming whether the page really seems to be finished load (maybe by looking at the icon on the browser tab?)

Also, on the Javascript console, you could try typing ‘wkof’ and pressing enter to see if it say ‘undefined’ or if it shows an Object {…}.

Finally, though I doubt it will make a difference, could you try moving Open Framework to run in the #1 spot?


#545

:point_right: [v7.0.1] - Added additional display settings

  • Placement on Dashboard
  • Max Bar Width
  • Current / Next SRS Level
  • Current Level Marker style (rad+kan, rad+kan_voc)

Other changes:

  • Improved the time label in Review Details when only one hour is selected.
  • Lingering ‘deleted items’ were fixed in an update to the Open Framework, so be sure to update that too if you’re seeing things like 文句する in your timeline.
  • Minor cosmetic change to the Bar Style drop-down.

(@sornvru @Fendon @TellowKrinkle @RysingDragon @rawo @souvenir @felix330 @maxb

@Arnagos,
I haven’t had a chance to look at your moving window issue yet. Please message me if I forget.


#546

Obviously the page is fully loaded and I already tried puting it in first position. wkof do return an object but I have no idea what it means


#547

I only mentioned the fully-loaded part because I’ve actually had a few times recently where it fooled me. Like I said, WK is loading really slow for me lately, and I’ve had a case where one little icon wasn’t loading, but the rest of the page was loaded, so I thought it was done, but the Timeline wasn’t showing up. Then, finally, when that one icon loaded, the Timeline suddenly popped up.

Anyway, I think I’m out of suggestions, except to turn off all other scripts temporarily to see if maybe something is interfering. :man_shrugging:


#548

Oh now that I think of it, you wouldn’t happen to use webGL for your timeline?


#549

Not webgl, but I am using svg.


#550

Just checked and firefox native is support is activated so yeah, I still have no idea. I will have to do without it


#551

Loving the update :slight_smile: Thanks for your hard work :slight_smile:


#552

I’m having this issue as as well. Firefox+Tampermonkey

Edit: Don’t know why I wrote greasemonkey :confused:


#553

Thanks for the new options. :smiley:
I just encountered a new problem with the overlay:

As you can see in the lower part of the picture the overlay is correct ABOVE the other items after mouseover. At the top of the picture, the over radicals can be seen through the overlay. So far this only happens, if Radicals are behind the layer, but can’t say for sure, as I have only one bar with enough radicals to fill the first line.


#554

Hmm… I wonder if this is related to your video driver (or at least the browser’s usage of it). The radicals use SVG (vector graphics), which browsers usually try to render with hardware acceleration. Which browser are you using? I might be worth checking how to disable hardware rendering temporarily to see if this goes away.

I’m guessing you’re using Firefox? That’s usually the one that has graphics driver issues.


#555

I think Burn Markers aren’t working? Switching between Enabled and Disabled does nothing.

Pictures

https://i.gyazo.com/77089a93b6589782b7dfc1cc9e871daf.png

But this is actually a Burn Review (I took this like an hour earlier):
https://i.gyazo.com/83a6b0c6455620cd7ccebc8a836eba97.png

I only pulled the update 45 minutes ago so I’m unsure if I took the before screeenshot before or after I pulled the update.


#556

Yes it is Firefox. I can’t check during the next 5 days as I have no laptop. Will check afterwards.


#557

Thank you for this update,

yet I can still report the (small) visual hicup :slightly_smiling_face:
image

the bar goes blue-pink-purple, whereas …
…the tooltip does purple-pink-blue, to display the same information (item type).


#558

:point_right: [ v7.0.2 ] - Fix “Burn” marker in “Current SRS Level” mode.

(@Jnk1296)


#559

I’m still undecided about that one. While “everything in one direction” is a good principle in some situations, there’s also the thought that each thing has a common/typical flow.

Bar-charts are typically visually bottom-up since the bars are planted along the bottom axis. And if I recall correctly, the one time I had radicals on top of the bars, people preferred them on the bottom.

The Review Details pop-up is visually top-down: Time, followed by total, followed by breakdown, etc. And the Items list has always been radical-kanji-vocab order (left to right, then top-to-bottom).

I guess I’d want to hear feedback from more people before deciding what route to take. If I make it an option, should it be an option to change the bars, or an option to change the Detail view?


#560

:point_right: [ v7.0.3 ] - Fix Review Detail window positioning and radical bleed-through in FireFox

@Arnagos @Powerpuncher


#561

Works like charm, thank you :slight_smile:


#562

To get it back temporarily right now:
Edit the script
Find the calc_bundle_stats function
Find the line in it:
if (item.data.level === wkof.user.level) {
Change it to:
if (item.data.level === wkof.user.level && item.object !== ‘vocabulary’) {


#563

No need, @rfindley has built the feature back in!