[Userscript]: WaniKani Ultimate Timeline

What are some tips for troubleshooting? I’ve tried switching off adblockers and tracking blockers. Absolutely nothing changes on my dashboard when I enable this script. I’m on a macbook using High Sierra (10.13.6), browser is Firefox (up to date at this moment, 69.0 nice).

Any other suggestions?

EDIT: I also have Burn Reviews and the script that adds the Kanji Damage mnemonics, but I just realized that both of those scripts aren’t fully working either. They both are saying something like “retrieving such and such” and it looks like they just get stuck like that. Starting to think this isn’t solely related to Ultimate Timeline.

Have you checked the console F12 for errors?

this is what it looks like:
03%20PM

But I’ve turned off content blocking and set custom permissions for WaniKani.
I guess I might try setting Firefox settings to default and then if I can get the scripts to work, change and check my settings back to how I had them one by one… unless someone has a better idea.

EDIT: It was also throwing up cross site scripting errors before, but I got those to go away.

There’s an issue with your IndexDB causing WKOF not to work. This happens frequently on Firefox. You could try clearing your cache and see if that resolves it.

Also I don’t think Burn Reviews is supported anymore, so I’d recommend getting the Self Study script, which has filters to review only burned items.

1 Like

So I determined the issue is that I went a little overboard hardening my browser and network security. I finally got Timeline to work, basically had to just walk back a bunch of security stuff.

Thanks for taking the time to reply to me. That makes sense about Burn Reviews because I still can’t fix that one.

ありがとうございま!

2 Likes

At a quick glance, [Userscript] Dashboard Progress Plus seems like a better version of WK ultimate timeline. But this was posted later… :thinking:

They serve different purposes.

image
image

I think something went wrong here. Suddenly I have only 44 apprentice items in the next two days, but according to my srs breakdown, I have 45 apprentice items.

I don’t think it would be 締める, since I Guru’d that one a while ago.

Which script are you thinking is incorrect, and why?

I vaguely remember seeing similar discrepancies in the past, I think maybe related to an unusual corner case. But as far as I can remember, I think the cause was addressed at the time.

You can turn on ‘details’ in Timeline if you want to see exactly which items are being counted. I’m not sure if there’s a way to do something similar in the breakdown script.

1 Like

The second isn’t dependent on the script, that’s raw wanikani right there. I’ll have a look tomorrow :wink:

1 Like

Today it seems to be correct. Not sure what happened yesterday. Sorry I couldn’t analyze it further.

Hello guys,

I’ve installed the WaniKani Ultimate Timeline on my work computer without any issues, and I did the exact same procedure on my personal computer and, sadly, nothing is appearing.
My personal computer is using Firefox browser (72.0.2 (64-bit)) (my work computer as well, but older version).
Let me know if you have any idea where it comes from, and also, my script knowledge is very limited.
I don’t know if I’m in the good thread to discuss this though.
Thanks in advance!

Open your Javascript console (press F12 and click the Console tab), and paste a screenshot of any errors you find.

Verify that the Open Framework script is the #1 script in Tampermonkey (assuming you’re using TamperMonkey).

Firefox often has problems with corrupting its IndexedDB database, which is where Open Framework stores Wanikani data, so you may need to clear the database (press F12, click on the Storage tab, find the database, delete it, and refresh)

2 Likes

Thanks for your answer rfindley.

It didn’t solve my problem, because all my database were already empty.
Though, it gave me the idea to try to change one of my browser parameter, from “Never remember history” to “Use custom settings for history”. And now, it does work!

Thank you still!!

3 Likes

I’m in love :heart:

1 Like

rfindley, thanks for creating this script! I use it all the time. However, with the new changes that were in preview for the past few weeks, and that have just gone live, this script breaks with exceptions on negative image positions (see attached screenshots). I am using the latest available (7.0.24) and the latest WOF. Chrome version: Version 80.0.3987.132 (Official Build) (64-bit) on a macbook pro (high sierra). any ideas why it might be failing? I tried resizing it, emptying cache & hard reloaded, etc. I like it better than the review forcast, so any thoughts would be appreciated.

2 Likes

We now have an official version kind of like this script, and it killed it! =P
I want both though, this script tells us so much more :wink:
Hope it can be fixed! =D

2 Likes

tl;dr: you can select position after recent forum activity to make it display again; albeit at a much less useful place!

Just as a few extra datapoints, for me the timeline breaks if you try to position it (account > settings > ultimate timeline > placement on dashboard) on:

  • Before next review
  • After next review
  • After level progress

It works, but the layout is cramped, on:

  • After SRS progress

If works as usual on:

  • New unlocks
  • After recent forum activity

n.b. depending on where it was positioned intiially, I noticed that sometimes you have to save the changes and refresh the page.

4 Likes

Can you replace the new interface entirely? It’s grotesque. The huge useless buttons could so better be used for real information.

Clearly something is going bonkers with WK…I am at level 51, not 50.

5 Likes

this has to do with the forums, not WK specially. Logging in & out should fix the level issue.