[Userscript] Wanikani Item Inspector


i want a list of all items i got wrong in the last 168 hours (last week)

the information i need is there it seems. I can filter based on “Failed Last Review” and set it to 168 hours, problem is, if the item ends up in apprentice again and get it right after a day or two, it will be removed from said list again.

There is currently no filter for doing this.

Version 1.20.7 is out - Download it at the link in the top post.

Fixing a bug where some Locked items were improperly marked in the Initiate SRS stage.

Items that were previously unlocked and then locked again due to a reset were improperly marked in the Initiate SRS stage. They are now marked as Locked.

1 Like

I notice that I can no longer see or add “next review” in the table popup. Was this removed?

1 Like

It works for me. Do you have messages at the console? How about the other dates? Can you get them displayed?

To add Next Review you need to select Review Date in the contents settings.

Thanks. I found it at the bottom of the list after changing “primary sort criterion” from “default” to “review date” and back again. But, it may have been there before and I didn’t see it.

1 Like




I would like to take this opportunity to thank @prouleau-さん for the honor ot naming this wonderful creation after me. I have no words to express my gratitude to such a grand gesture. As to the reasons why I have been bestowed such an honor, only PRouleau-さん can answer that. I can only be humbled by his generous actions.



My failed review items dosn’t seem to load. also whenever I set the script to export kanji onyomi and kunyomi readings it dosn’t export.

1 Like

What is the parameter of your Failed Last Review filter? By default it is 24 hours, so if you didn’t fail a review in the past 24 hours no items will show up.

It works for me, so I need more details to see what is your problem. Can you post a screenshot of your table filters and export settings?

Do you export onyomi and kunyomi for your failed last review table? Then nothing will export because you have no item in this table.

Edit: your message was about loading the data, not having no data selected. This is different. Do you have messages at the console?

1 Like

Thank you. I think, the problem started when I changed the time format, from 24 to 12. that was a few weeks ago. I changed it back, but since then, it hasn’t loaded my failed last review items.
as for the exporting Kanji readings, that has always not worked, even before I changed the time format.

1 Like

Version 1.20.8 is out - Please download it at the link on the top post.

The fixes the item type export bug reported by @SARUOU

@SARUOU do you have the Reading By Type pop up element configured in your Failed Last Review table? If so this version will probably fix the Failed Last Review bug as well. Otherwise I need more information for this bug. Could you please;

  • Post a screenshot of your console errors messages?
  • Post a screenshot of the filters and contents tab for the failed last review?
1 Like

This is not the problem. I have tested the two time formats and both work well for me.

Which one is the contents tab?


1 Like

This is not what I need. I haven’t been clear enough I guess. I try again.

I need the Failed Last Review table under the Tables tab. Beneath that I need the Filters tab and the Contents tab. Please make sure I have all the settings under these two tabs.

Also make sure to include a screenshot of the Javascript console for the error messages.

How do take a screen shot of the Jarva script console?


1 Like

You open up the console (F12 on Chrome and Firefox) and take a screenshot of what shows up.

Anyway I don’t need this screenshot anymore because I was able to reproduce the problem. Your Level filter doesn’t have its parameter defined. This causes the filter to bomb before your items are selected. You need to select which levels you want to filter and provide that information.

Even if you fix this issue your Failed Last Review table will still not work. You have way too many filters enabled and several of them are configured in a way that no information will pass the filter. You will get a message that no items matches you criteria.

The purpose of a filter is to select which items will display. If you want to control which information is displayed in the popups you should used the Contents tab settings. Filters only control which items are selected for display.

When you select more than one filter an item must pass them all to be displayed. When you have many contradictory filters like you do no items will match your criteria because no items pass all the filters.

The correct configuration is to have only the Failed Last Review filter enabled. All other filters (including Level) should have their checkbox unchecked.

1 Like

Thank you it’s working now! :slight_smile:

1 Like

I’m not sure this is related to the script itself or something on the wanikani end, but my reviews streak is suddenly gone, and I’m pretty sure I didn’t miss a day.

Likely to be related somehow, I noticed I had to login again when I opened the dashboard today, which is weird cause I have remember password on and it had never asked me before unless I had logged out myself.

Edit: Also, it shows me the calendar all the way up to 2012, which I’m also pretty sure wasn’t the case before :thinking:



Edit 2: Never mind, confused the scripts.

1 Like

You probably saw it already in the Heatmap thread, but you just need to update the script and it should be fine

1 Like