[Userscript] Reorder Omega

Would be funny if there were eventually enough iterations that it became Omega 3


Please… I’m still dealing with Omicron sniff

1 Like

I bumped the version up to 1.0.0 now that most of the initial bugs are cleared.

Also, you can now copy and paste presets and actions using CTRL + C / V while focused in one of the selection boxes in the presets tab of the settings
@Sinyaven This will enable sharing presets, as you suggested. For example, this is the “None” preset

{"preset":{"name":"None","selected_action":0,"available_on":{"reviews":true,"lessons":true,"extra_study":true,"self_study":true},"actions":[{"name":"Do nothing","type":"none"}]}}

Would you mind attempting to share your custom preset?


Seems to work great – here is my lesson order preset:

{"preset":{"name":"Lesson Order","selected_action":"0","available_on":{"reviews":false,"lessons":true,"extra_study":false,"self_study":false},"actions":[{"name":"First any really old lessons (from before previous level)","type":"filter","filter":{"filter":"level","level":"1..-2"}},{"name":"After that...","type":"freeze & restore"},{"name":"Learn current radicals & kanji","type":"filter","filter":{"filter":"item_type","item_type":{"radical":true,"kanji":true,"vocabulary":false}}},{"name":"Radicals first","type":"sort","sort":{"sort":"type","type":"rad, kan"}},{"name":"But prioritize current level over previous level","type":"sort","sort":{"sort":"level","level":"desc"}},{"name":"After that...","type":"freeze & restore"},{"name":"Do vocab from previous and finally from current level","type":"sort","sort":{"sort":"level","level":"asc"}}]}}

However, I have noticed that if I have the JLPT filters script active, selecting existing presets in the presets list of the settings dialog throws errors. In the wkof settings module it seems to try to load the setting for filter_by_jlpt_level which returns undefined, and in line 405, it then tries to read value[opt_name] (undefined["0"]).

wkof code screenshot


Or maybe I have made a mistake when I tried to reset the Reorder Omega settings by deleting the IndexedDB Reorder Omega settings entry. I noticed that I also have to delete the [dir] database entry or else the default presets are not restored, but maybe I have missed additional necessary steps.

1 Like

Seems to be working now. Thanks!


Ah. I was encountering this while I was writing the script, but the issue went away at some point and I couldn’t replicate it (still can’t), so I thought it was resolved somehow. I think I just need to insert all registered filters’ defaults into your settings after they are loaded.

edit: I just pushed 1.0.2 which I think should fix this for you

1 Like

Thanks, it’s working now!

Another very minor thing (not urgent): during extra study mode, WK allows to use the audio button even before answering – however, the audio is not updated after Reorder Omega changes the current item. So if I start extra study, get asked vocab item A, switch reorder preset and now get vocab item B, and then click the audio button, it still plays vocab A. Maybe you can add a call to wkRefreshAudio() somewhere.

1 Like

Update 1.0.3:

  • Fixed item having wrong audio when you switch preset (thanks @Sinyaven)
  • Fixed first item of self study sometimes not accepting answer (question type was not matching)
  • Fixed switching between presets that filter; a preset should not affect which items are available to any other preset

Hey helpful people.
I’ve been struggling with the Reordering scripts since Reorder 2 stopped working for me this week. Basically, the plug-ins refuse to load. Other simple plug-ins seem to be working, like Override (Ignore button.)
I’ve installed Omega, updated Open Framework, and tried disabling everything except the Framework & Omega with no results still.

Running Chrome. Any hints as to how I can properly troubleshoot and identify what the issue is?

I appreciate any help and look forward to zipping through reviews again,

1 Like

Open up the console window (either F12 or Ctrl+Shift+I), switch over to the “console” tab and check if there are any errors in it. They would be red. If there are, take a screenshot and post it.


Ok, here’s what I’ve got. That bottom link takes me to the Pitch Accent plug-in (disabling it didn’t do anything, but worth a shot.) No red.

What userscript manager are you using? Tampermonkey? Does the Tampermonkey popup show Open Framework and Reorder Omega as running on the page? Are they up to date? Does it neither work with script compatibility mode enabled nor disabled (it should work in both cases, but just to make sure)?

Also, a recent Chrome update seems to have introduced some problems with IndexedDB – the other reported cases had error messages in the console, but maybe your case is still related? Can you check the IndexedDB for any suspicious entries? You could also try deleting the entire “files” IndexedDB, but this will delete all your userscript settings.

1 Like

Deleting IndexedDB files fixed it right up. Thank you so much!


Now back to those reviews :crabigator:


Getting a new and interesting bug where I will complete a set of reviews, change my ordering preset during the same session, and suddenly have the reviews I just completed come back.

^ me completing the review

^ after changing the preset away and back

Even scarier is the fact that it was enlightening when I first did it but upon returning apparently it’s burning? I don’t know if it would actually go through if I answer it again now, but that’s a little concerning.

1 Like

Haha, that is a funny one. I know what the issue is and will fix it tomorrow.

It won’t, WK tracks the state of an item on their server, so no need to worry about that

1 Like

There actually used to be a bug on WK where you could burn an item directly after lessons. :sweat_smile:


One more thing. I figured this dropdown just didn’t exist on the lessons page, but I found the preset list on the very bottom of my page for some reason:

It can’t be clicked either, so I don’t know what is going on.

This is fixed in v.1.0.6. I tried to make Extra/Self Study better when you switch between presets but failed to account for how that would affect regular reviews.

Oh, that’s weird. It was working when I was testing before release. Anyway, should be fixed in 1.0.6, I just had to add a line of CSS

1 Like

I feel like I’m being a bother, constantly coming back with new things, but I’m having another problem.

I have a preset that, if I understand it right, is supposed to sort my reviews by Type, SRS, and then Overdue (so that if I don’t have any radicals or kanji to study the higher-SRS ones will be next, and among reviews of the same SRS level they’ll be sorted by most overdue to least).

It didn’t seem to be working like it seemed like it should, so I was going to reverse the action order, thinking maybe I had the order of operations reversed. I still don’t know if I did, because the settings menu isn’t letting me change the order, and is being weird in general. When I press the up or down arrows nothing changes, and in fact when I try to click on any of the actions in that window, or any of the presets in the top window, the highlighted selection snaps back to the top. It’s not really something I can screenshot, but just imagine that I’m trying to click on everything under this top preset:
When I do it jumps back to the top. The same thing happens with the actions order panel.

Edit: Upon a refresh the snapping back thing went away, so I don’t know how to reproduce it. The reordering arrows still are having trouble though, not working or only working on certain actions, and the more I mess with it the less cooperative it seems to become.


I believe it can be reliably reproduced by opening the settings menu, clicking “Cancel”, and then opening the settings menu again.

1 Like