[Userscript] Keisei 形声 Semantic-Phonetic Composition

Hmm. Could be as I disabled this one and it worked but now it happens again.

This script stop showing info during reviews. After I got a wrong kanji, I usually read the info but it is not showing any info. But outside the reviews, the scrip works fine. And since the script code relies on lots of external files, I have not idea on how to fix this. Is anyone having the same issue?

1 Like

I don’t understand why this feature is not directly available on Wanikani, it’s a missed opportunity :face_with_monocle:

4 Likes

It would help a lot with memorising readings. At the very least, they should incorporate this in Wanikani and make it optional for each user.

3 Likes

Yeah, it stopped showing up for me as well. It’s a bummer because it’s the best script on the website alongside the Reorder Script

2 Likes

@jonmoxley

4 Likes

Thank you so much!

1 Like

Thanks a ton!

1 Like

I’m wondering why the phonetic-semantic section in my lessons and reviews displays with no gap between it and the section above? Not that big of a deal but it would be nicer to read if it was spaced out. Looking at other screenshots in this thread it seems not to be a problem others are experiencing. I’m using Chrome if that makes any difference.

The first thing to do is disable all other scripts to see if it’s caused by another one conflicting.

1 Like

I’m not sure why I didn’t try testing that before. :man_facepalming:t2:

A script called Integrated Dashboard Overhaul is causing it. I really only have that because it puts the critical review time in bold on the Review Forecast. I’m not sure why it would be having an effect in Reviews and Lessons.

Don’t know if the script author is still around but I’ll post in that thread and see if someone can resolve the conflict.

An alternative script is WaniKani Ultimate Timeline. It can be configured to display critical review times as well as burn reviews with these markers.
image

1 Like

Thanks. I know lots of people use this one. I hadn’t tried it before. It is good. The white review markers don’t do quite the same thing as that other script but still useful.

Anyway I think I may have fixed my own problem by commenting out sections of the script through trial and error until it worked!

Anyone else having issues getting this script to run? It stopped working for me today.

1 Like

WK made some under-the-hood changes to the way the lesson screen works, which breaks several scripts. I have been working on a fix, but it’s not quite finished yet. For now, you can either test my fixed version:

or you can enable the script compatibility mode in the WK settings.

UPDATE: My pull requests for Keisei, Niai, and Rendaku information were all accepted, so the official installation link in the OP now again provides the most up-to-date version. To make sure that nobody accidentally installs the now outdated versions that were linked above, I changed the link targets to point to the official install locations. Please report any bugs – especially with the compatibility mode disabled – so that I can fix them before the WK team removes the compatibility mode.

10 Likes

The script stopped working for me completely, both in compatibility mode and without.

The browser console has this to say:

Syntax error @ "WaniKani Keisei Phonetic-Semantic Composition"!
##########################
JSHINT output:
##########################

F_a/s</<@eval:4:80
t@eval:3:191
E_u/<@eval:4:244
create/<@eval line 2 > Function:67:477
create@eval line 2 > Function:69:193
c@eval line 2 > Function:7:231
runListeners@eval line 2 > Function:7:202
anonymous/</</<@eval line 2 > Function:70:232
v@eval:13:204
eval line 2 > Function:69:14
SyntaxError: expected expression, got '.'

Please help, semantic-phonetic composition is an amazingly good tool for helping me learn.

What web browser are you using? And is it up-to-date, or are you using an older version? Maybe you can also tell me your OS and script manager.

The error message is not that helpful, but my guess is that your browser does not recognize the optional chaining operator (?.) I am using. According to this browser compatibility table (near the end of the page), it should work on all current web browsers, but it was only implemented last year, so maybe your browser does not support it yet?

1 Like

Yeah, I’m using an older version of firefox. That’s probably why then. Thanks for the help.
(I think firefox is getting worse in may ways with each release, so I am lagging way behind in updates)

For now you can downgrade to the version of Keisei that worked for you:

Install outdated version of Keisei

You probably also have to disable automatic updates for this script in your script manager. And then you need to activate the script compatibility mode that WK offers (I don’t know how long WK is going to support this mode).

I have to think about if/how I want to support older browsers.

1 Like

It’s very hard to keep supporting old versions. The ?. operator is going to be used more and more. For Harald, i think you’ll unfortunately have to concede at some point and either update or change to a new browser. It’s also about security updates and such, and compatibility of course.