[Userscript] Dashboard Level Progress Detail. update to broken script

Thank you so much for this! It’s one of my favorite scripts and I’ve been hoping somehow it might get to work again. Thanks so much!!!

1 Like

Many thanks for this.

1 Like

Thank you so much. I wanted this script to be fixed so badly so I’m glad to see it being done well. I updated it and it seemed to work for me because of seeing the 90% marker, but it still shows the old information from when the servers stopped, being a level behind me. I don’t know if it’s broken or just not updated the displayed information but either way there’s a problem there. Hopefully you can fix it because as it is it’s basically not working for me.

None of the userscripts seem to work for me… instead I get an error log:
TypeError: global.wkof is undefined
I guess somehow the Framework is not working for me…
Is there something I can do about it?
Firefox & Greasemonkey is up to date.

Thanks for the script!
You may want to remove/update console.logs around line 115.
level_list[15] may break the script

Hey there. I don’t know for sure how to fix this because it worked instantly to overwrite the old cached data for me, but maybe it’s something with your Wanikani Open Framework installation? Installing Wanikani Open Framework Make sure WKOF is at the top of your userscripts list.

Yuuup whoops, should be good now.

1 Like

Yay! Thank you so much!

So uh, I don’t know if it’s working for me now but since my WaniKani has become a bit of a mess now that I’m in Uni I’ve noticed a small problem with how it’s laid out.

Not sure if it’s an easy fix or not to make the levels go in proper order or if it even should show 8 at all but I’m doubting it’s a big deal since most people won’t see it.

I’ve also realized it’s still not working because it still shows the app store, so I’m pretty sure that means it’s not updated the cache. I’d really appreciate some help because the only help I can find is just saying to have the open framework on top.

All of those should be showing because you haven’t Guru’d them to 90% yet, so that part is working right. The 8 being out of order is mysterious, and I thought I had tested the sorting across more than 2 levels but I can take another look. Edit: just realized level 9 is backwards too, should be radical, kanji, vocab but it’s backwards. I’ll definitely have to look into it somehow.

As for the app store, I didn’t touch that part yet even though I know I can/should remove it.

Oh, ok. Also thankfully comparing that screenshot to my current state I think the scripts working for me. Thanks for getting this script up and running again (especially with that nice 90% bar), I’ve needed this back. Let’s just hope you don’t have a hard time sorting out the order or the app store showing. :wink:

Oh no, it’s gotten worse XD Well at least it’s consistent. And look at that! 500+ burned! WOOO!!


Oh and uh, it looks like there’s a problem with the colour on the Level 6 bar. There’s a thin line of purple between two pinks. Weird.

Just put out an update and I think I did it right this time. I had been inadvertently reversing the list right before showing it…


That’s done it! Thanks.
Though there’s still that problem of the purple line in Level 6. Less important but still an interesting bug.

Yeah I can’t change any of the visual stuff since I don’t know how to do that. Even getting the 90% marker to show was mostly guesswork.

Oh well. Shame but not important. If I were to guess it’s that the whole thing is purple and the pinks are put on top of it, so slithers can appear when the pink boxes don’t line up right from something like rounding. But hey, what do I know. :stuck_out_tongue: At least with the levels in order again it’s made a surprising difference in readability, which is good.

Hi thanks for this script it’s really nice to see which levels you have trouble with and what your progress is.

I’ve just reached level 60 and the script has stopped working, it throws an Empty string passed to getElementById() error. I think it’s just because there’s nothing to display anymore… I’ll deactivate it but wanted to tell you about this marginal bug.

Could I ask you to also add a 50% marker?

Hi, sorry but no. I don’t personally want a 50% marker for myself and even getting the 90% marker was a lot of work because I’m not good at this sort of thing. I did it purely for myself and then shared with everyone else as an afterthought. Sorry I couldn’t help you further.

2 Likes