User synonyms broken?

Post update, I’ve had several examples of my synonyms not being accepted, here’s one example:

1 Like

It seems “to face towards” was added to the block list for 向ける

“To face something towards” would be accepted.


Thanks for pointing this out. In fact, “to face towards” is on the warning list so it should give you a shake and a chance to retry, but we have a bug that is causing something to be marked as incorrect if it is both a user synonym and on the warning list. We’re working on this, but for now I’ll remove 向ける from the warning list so that you don’t have it marked wrong.

Update: this bug has now been fixed, so I’ve added the shake and warning back for “to face towards” :slight_smile:


I’m surprised that this bug survived the radical changes made to the review code :laughing:


Thanks for that! I can understand why it was on the banlist previously, I mainly had it there as a way to shorten “to face something towards”.

1 Like

I also just had a synonym not accepted as correct. There’s a slight difference in capitalization, but that should still count as correct, shouldn’t it?

This one is in block list. After all, there is also 当たる.


User synonyms to be a bit broken for me too. It always marks user synonyms wrong and and usually takes multiple tries before the answer is accepted. .

EDIT: Seems I have to open the item info before it accepts the answer, though there were some instances where it’d still take a few more tries after doing so.

We have had a few issues raised about user synonyms being marked as incorrect recently. I have been looking into the issue but so far I have not been able to reproduce the problem. If anyone encounters the issue and is willing to help out by debugging the issue via a screen-sharing session then I would really appreciate the help in getting to the bottom of what is causing the problem.

If you are willing to help and can reproduce the problem fairly reliably, I am available from 9am BST most weekdays. If you can help please send an email to and mention you are wanting to do a screen sharing session with me related to the user synonym issue and I will then be able to send a link to a screen share meeting as soon as I see this message. Alternatively we can schedule a time that would work for both of us if that helps.

1 Like

User synonyms are broken on my end too. For some reason, it’s only wrong the first time, while using the Double-Check extension, and opening item info inbetween answers. This is happening on both radical and kanji reviews for me.

To be very clear, the behavior is such that:

  • I am told the answer is wrong

  • I check the item info

  • I see that I have the user synonym for the exact answer I wrote

  • I delete the answer, because I am using the Double-Check extension

  • I then enter the exact same user synonym answer again and it’s accepted

  • If I do not open item info, it will not accept the user synonym no matter how many times I delete and re-enter.

This is consistent behavior, and it exists on user synonyms that I have had written down for at least a few days prior. I use these user synonyms because they are the versions of the kanji and radical definitions on jpdb, my primary SRS system.

I’m not really available for any screen sharing, but I hope knowing that this behavior is a first-time thing on reviews when using the Double-Check extension (and opening item info before entering the answer a second time) helps pinpoint where it might be going wrong.

To be clear, this issue only popped up today for me. Maybe it existed yesterday, but I only did 22 reviews that day so I’m not sure. I did 100 reviews two days ago, and the issue did not exist then.


Thanks for taking the time to write that up. This sounds like an issue with the “Double-Check extension” that you are using. The “Double-Check extension” isn’t supported by Wanikani so there isn’t much I can do in this case. You might like to bring up the issue with the author of that extension as that would seem to be where the issue lies.

Sorry, to be very clear, it is not an issue with the extension. I disable the extension, and it will still not accept my user synonym answer. The only difference is now I cannot fix my answer at all. I shared my usage of the extension, because it’s the only way I can get the user synonym to be accepted at all.

1 Like

Okay, here is the behavior with the Double Check extension disabled:

  • I try entering my user synonym answer 10 times, it is not accepted at all, any time.
  • I open item info
  • I press enter to let me retry one more time
  • I enter the user synonym and it is accepted

I apologize for including the Double Check extension in my previous message.

Thanks for the clarification. I was not aware that you had so many scripts installed. We have had users who report this error come back to us saying that removing the reorder scripts seemed fix the problem. You could try doing that and see how you get on.

As you have user-scripts installed this probably all the help I can be I am sorry. The problem lies in code that I can not change.

Thanks for the help and quick responses! I just wish I knew why this issue only popped up today, and didn’t exist a couple days ago.

I’ll just keep looking at item info to fix this issue, until it’s resolved some other way through an extension update or WK update.


I am not super clued up when it comes to user scripts, but I think they may auto update. If this is indeed the case that might explain why you and others are seeing this issue now. I have not released any code in the past few days that would have resulted in the issue you are seeing. I know that doesn’t help you right now but it might explain what is going on. Can you revert your installed user-scripts to sometime prior to you noticing the issue!? The best thing would be to figure out which script is the culprit and talk to the script author.

1 Like

I’ve finally gotten an example without any userscripts enabled. The issue still stands. (I did a full investigation of all recently updated scripts before trying to disable all scripts entirely, and disabling all that were updated in the last 3 days did not help also.)

This example may not be entirely sound, as I did have to open the term in another tab, add the user synonym, close that tab, and then test it on the review page that was already open. I would have tried to provide an example with an existing user synonym, but I have too many reviews to reliably grab one of those. The user synonym that I added in the other tab did show immediately here once pressing the item info button though.

Also not pictured, I tried disabling the Breeze Dark style on Stylus, and did the same test - no change in the results from that.

I don’t have any more time to investigate this further today, but I will stay updated on this thread. Thanks for the help so far!


Thanks so much for you persistence.

This comment helped me track down the bug. The issue would only show up after you have reviewed over 100 items. I have deployed a fix for this. You will need to reload the review page for the changes to take affect. If you are mid review, please use the wrap-up button so you dont lose any progress on half answered items (i.e. ones where you answered the meaning but not the reading, or vice versa).


So glad I could help! In the future, I’ll make sure to disable all userscripts before providing any information, so I don’t muddy the waters.



This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.