TaperMonkey often not loading

Hello ,

I have ( since before they annonce the script rework https://community.wanikani.com/t/we-are-starting-to-retire-script-compatibility-mode/59285/28 ) an issue , that i need to reload for most of the time the page for the script to be active .
it look like TaperMonkey do not detect or fail to load script on Wanikani .
If someone have a fix or an idea ^^’ .


1 Like

I’m glad I’m not the only one who mistakenly thought TamperMonkey was called TaperMonkey.

I’ve had this issue as well, for me with the script for adding furigana to kanji when posting on the forum. I don’t know the cause nor do I have any solution. But I don’t think it’s related to the script compatibility changes.


I once had a similar issue. Deinstalling and reinstalling Chrome provided temporary fixes, that is the problem went away for a while and came back. There were recent releases of new versions of Chrome and TamperMonkey that appears to have fixed the problem for good.

1 Like

Happens to me too. I always just refresh the page until it works. I’ve been to lazy to troubleshoot the real issue.

1 Like

This was discussed in this thread previously

For me, the only fix that worked was changing TamperMonkey for ViolentMonkey and importing scripts there (took like 20sec, its not as bad as it sounds! idk why i tried that one as a last resort haha). No problem with violentmonkey so far, but some other solutions from the thread might also
work for you?


I’ve had this the last few months too. It was asking for donations all the time so I thought it was because I haven’t paid up!

I backed up and reinstalled the scripts and changed the permissions to allow tampermonkey to read all pages instead of just wanikani and then, after having it work properly, deselected that again so it only reads wanikani. So far it has been working again. I also have no idea why it fixed it. But they also stopped asking me for donations! I will donate with remind me later. Later.

1 Like

Thank you all ! i m going to try Violant monkey and see if it work better