[Suggestion] Turn off auto capitalization on mobile

Hello!
When reviewing on mobile, it’s very tedious to always press shift twice to turn off the capitalization of the first letter, since most of the readings are supposed to be written in hiragana.

This should be easy to solve using the attribute:
autocapitalize="none"
In the text input field. I haven’t tried it myself, but according to my research, that’s how to avoid the keyboard to start without auto capitalization, on both Chrome for Android and Safari on iOS.

1 Like

There are mobile apps for Android and iOS. They’re not official but they’re better than using a mobile browser.

2 Likes

Hey Tim, unfortunately they already have autocaptialize turned off. It’s an issue with the browser/device keyboard implementation in this case :frowning:

<input autocapitalize="off" autocomplete="off" autocorrect="off" id="user-response" name="user-response" placeholder="答え" type="text" lang="ja">

2 Likes

Hmm, though it looks like "off" has been deprecated for autocapitalize and autocorrect which should be switched to "none".

autocomplete="off" is still correct

@viet tag-a-lag

3 Likes

Yeah, it should be “none”.
I even wrote “off” myself even though I knew :stuck_out_tongue:

Interesting… I didn’t know these attributes were available, though it certainly makes sense. I’ll have to experiment on my server to see if my tablet responds to them. If so, I’ll be sure to add them to my Quiz script.

They’re non-standard but respected by some devices. Better than nothing.

@rfindley @Timlarsson Can you you give the first field on wanakana.com a shot?
I made the adjustments there, curious if it made a difference.

I don’t really use a phone or tablet and browserstack isn’t always definitive :stuck_out_tongue:

@Subversity
It didn’t work for me, sadly :frowning:
I’m using Swiftkey on my phone though, and maybe it’s auto capitalization setting is overriding the text area’s attribute :confused:

Seems to work for me. I’m on a Samsung Galaxy Tab Pro 10.1. I don’t normally have auto-capitalize or auto-correct turned on, but I did for this test.

I first had to find a site that had plain input fields, so I could make sure auto-capitalize was working. That’s surprisingly more difficult than I expected :slightly_smiling_face:. Anyway, typing on the wanakana.com field gives me hiragana… no katakana.

1 Like

Hmm, yeah some keyboards try to be too helpful.

Well the easiest solution for WK is to use toHiragana on the input, which won’t attempt to convert to katakana at all. Since all WK words have an associated hiragana reading, even the few katakana ones like アメリカ人.

Well, It seems like it works for @rfindley at least (Do you know what keyboard you have? Samsung’s own, google, any other?).

I think Swiftkey was the culprit here at least, which is a bummer. It came pre-installed on this phone, and I can’t be bothered to change :stuck_out_tongue: I could just turn off the auto-cap but I am so used to it being active, that it has become really helpful.

But wait, so WK will never require a katakana answer? Then it’s a useless feature to have to begin with. Unless some user script uses it, in which case it could be made optional in the settings menu.
Edit: (and off-topic). I see a “01” next to my avatar. Isn’t that supposed to be my level? I’m at level 2 now, and have been for a day… is it just a little bit slow to update? (just like the badges here in the community, which I got “first mention” on the… fifth or so.)

I’m using the default Samsung keyboard. I know a lot of people complain about it, but I somewhat prefer it. I’m not exactly a fancy-feature connoisseur :slight_smile:

I’ve tried swipe-like features, autocorrect, autocapitalize, etc, but I find I’m actually faster and more accurate typing two-thumbed with all other features disabled.

Yes… I think they’ve been having issues with it lately. Some people have seen theirs lag by 4 days or more.

1 Like

I just tried Google’s keyboard on your site, and it works wonderfully. Also went to my forum, and it had auto capitalization when writing a new post. So for users who don’t use Swiftkey, it would work! :stuck_out_tongue:
Now I just have to check the reviews if it works with the deprecated “off” instead of “none” already.

Well, it’s not useless but potentially inconvenient for WK answer input.
I’m updating the config option to accept a choice of conversion method for the IMEMode anyhow!

Well, I did make that comment only focusing on the confined scenario “WK answer input” (and assuming WK never wants katakana)… then it would be inconvenient to let users (accidentally) type in katakana :stuck_out_tongue: But sure, useless is a strong word!

My old UI design teacher would argue it’d be “useless” though, again in the WK answer input case if katakana never is requested.
“Don’t give the user the option to do what he’s not supposed to do”.

HOWEVER I just noticed that フランス人 is an acceptable answer, using katakana. So the feature is neither useless nor inconvenient really :slight_smile:

Also, using Google’s keyboard, WK review input with “off” instead of “none” works fine. So this was a none-issue to begin with :smiley:

In my opinion, those answers should require katakana. Using hiragana is not really correct, so I always use katakana to make sure I’m used to seeing the words as they should be written.

1 Like

You always see the word how it should be written. As long as someone knows the hiragana option is just for convenience, it’s not a big deal.

Just to throw some oil on the waters, I use Swyft on a Nexus 6P and it works fine.

SwiftKey or Swype?