English input converts to katakana first


#1

Hi everyone,

I couldn’t find the topic like that by search on “English input katakana” keywords.

I am using an Android mobile phone with SwiftKey keyboard. The matter is, that if I am using English layout to enter the reading the first symbol is always converted to katakana while all the other to hiragana. The answer is not accepted by the system. So I have to switch to the Japanese layout of the SwiftKey to enter hiragana every time when I need reading and back when I need meaning. That’s not a big deal for me for the current moment, but I believe this still is a bug worth mentioning.

That’s the screenshot


#2

Make sure the first letter in your input isn’t capitalised - a syllable starting with a capitalised letter will end up being converted to katakana.


#3

All right then. The automatic capitalisation in the beginning of the sentence…
The case is solved. Thanks!


#4

At least with most keyboards, WK doesn’t set ‘autocapitalization’ mode; SwiftKey seems to be decided to do this on it’s own. I don’t think this happens with Gboard.


#5

As others have stated, this is a Swiftkey issue. SK doesn’t recognise various HTML attributes on input fields which are what control autocapitalization. I have this issue with Kaniwani as I use that through a browser, and I’ve taken to swapping to GBoard when doing reviews there.

I recommend WK since you’re on Android. It works brilliantly, forces lower case correctly for SwiftKey, and also has a nice feature of disabling predictive typing so you can’t “remember” by what options are presented by the keyboard.

I found mention of someone having reported it a while back, and it not being fixed, so SwiftKey know about it.


#6

Thanks, I’ll try it. In fact I can switch the autocapitalisation off, but this will be permanent, so if the application works fine, then it will be really nice.