[SOLVED] Alternative to Windows 10 Japanese keyboard

Good afternoon dear Wanikanians,

My Japanese keyboard on Windows 10 doesn’t work and after some search I realized it’s a known problem but Microsoft didn’t bother creating a proper fix for it ¯_(’__ ')_/ ¯

After unsuccessfully trying some solutions found on forums, I give up and am looking for an alternative to this embedded IME keyboard.

Do you know of any online service that would allow me to type romanji and get instant kana recognition + kanji suggestions?

I found Lexilogos but while it turns my romanji to kana, it doesn’t suggest associated kanjis (there’s an extra box to search for kanjis).

Take care!

Robin

1 Like

Care to share what the specific issue is? Depending on the issue, maybe Google’s IME would work for you. Not that I’ve had an issue with the Microsoft IME.

3 Likes

Google IME has been working for me.

While on this topic, does anyone have suggestions for an IME on Ubuntu based distros?

2 Likes

Quite. You might need to run it past us again as to precisely what the issue is.

1 Like

@seanblue, Google IME was exactly what I was looking for! I basically do everything in Chrome so after installing the extension, typing in Japanese is just a click away.

Many thanks!

The issue is even irritating to explain and probably to read about, so now that I’ve found a perfect solution I won’t bother you with it. ; )

I remember that it took me quite a while to make a japanese keyboard work for me (I use a arch based distro tough, anyway this is what worked for me https://www.ostechnix.com/setup-japanese-language-environment-arch-linux/), since ubuntu is debian based maybe this will work https://wiki.debian.org/JapaneseEnvironmentE
Also seems that someone else had the same problem so if the last solution doesn’t work you could give this a shot https://askubuntu.com/questions/1032721/how-to-enable-japanese-input-in-ubuntu-mate-18-04

1 Like

You have to copy the IME files from a known working Windows 10 PC to get it to work. Known issue and that’s the process I had to take on two separate occasions. Once you copy those files over, reboot, it works just fine.

I am using the Mozc (2.23.2815.102) IME on Ubuntu 19.10.

It works fine, only when you trigger for the first time in a session from US to IME, it always starts in the ‘direct input’ mode and you have to manually switch to ‘hiragana input mode’. Afterwards the hiragana mode is remembered even if you switch to US and back to IME.

1 Like