Radicals not showing correctly [Solved]


#1

Hello
Since few weeks I have an issue regarding radicals. Some radicals are not displaying correctly.
I have been talking with the Wanikani help assistance through mail but in the end it was hopeless.
The radicals concerned are:
-Helicopter
-Lantern
-Coffin
-Flowers
Capture d’écran_2017-07-28_19-57-27


I looked on other topics related to mine and followed the solving methods without any results unfortunately.
I am using Mozilla Firefox 52.2.0 (64-bit) under a GNU/Linux OS (Gentoo 64 bits amd).
I erased the cache and the history of my browser, I disabled my extensions, I tried other browser (Chromium and Google Chrome without any extensions) but the result is the same: These radicals are not displaying.

What did I miss ?


#2

Open the developer tools by pressing F12, click on the network tab, and look for things not downloading. They should be highlighted in red, at least on Chrome. Maybe post a screenshot of the developer tools.


#3

I had a similar problem last year and I think all I did was install some cjk fonts through my package manager. Unicode </3


#4

@Helix I looked on the network tab in developer tools in Firefox and Chrome but nothing appeared wrong to me, all the content seem downloaded. I also tried by disabling the cache option in Chrome but nothing changed.

Can you see something wrong on those pictures ?

@ccookf The cjk fonts are already installed on my system. I have no problem concerning kanjis, hiragana or katakana. This issue is only related to few radicals.

Since the Wanikani site created their own radical and my browser need to download this font to make it work I think the issue comes from here but I can’t find any evidence of it in the network part of developer tools.


#5

I have to agree, it looks correct to me. Here’s a twist, however: The radicals that aren’t working for you do not use the WK custom font. I can even write them here: 耂 覀 开 艹

This is what the above looks like for me: 15

So maybe it is your CJK fonts. Have you made sure to update your font cache? Something like sudo fc-cache -v should do it, I think.


#6

I managed to fix this issue by installing new fonts (Gentoo OS):

emerge media-fonts/kochi-substitute
emerge media-fonts/arphicfonts
emerge media-fonts/baekmuk-fonts

And then update the font cache:

fc-cache -fv

Restart Firefox or any browser, looking in the font parameters of the browser.
(Firefox 52: Preferences > Content > Font and Colors > Advanced)
And then specify the installed fonts for the Japanese language.

I can now see the radicals correctly, Thank you for your support.
I would like to ask to not remove this topic since there is not that much information on this kind of problem on internet and it could help future person to avoid a headache.