Please Send Help! - Scripts FIXED

Trick number one: try restarting your browser?

No dice :cry:

I was using safari, so I tried setting up my account on chrome. This works! But safari still doesn’t work. So, half a solution so far.

What isn’t working?

Any of my scripts, I just get vanilla WK. Tampermonkey is on, the scripts are showing as on, but to no impact. I have tried uninstalling and re-installing the scripts, and restarting my browser.

Did you also restart your computer?

I really should have thought of that :sweat_smile: but it has not worked either

1 Like

Have you installed Wanikani Open Framework? IIRC some scripts require it.

I have, thank you. Open framework was also one of the scripts I reinstalled, just in case.

1 Like

I have cleared my cache, and my cookies, and cleared my history too.

Open the Javascript Console and post any errors you see there. (Opening the console in Safari is more complex on Safari compared to other browsers. Since I don’t use Safari, I don’t remember the procedure, but there is plenty of info via Google)

1 Like

From what I can find regarding that error, it sounds like Safari is the problem. Basically, userscripts and other plugins should be excluded from Content Security Policy, but Safari isn’t doing that and other browsers are.

The strange part, though, is that I haven’t seen any other Safari users mention this, and it also sounds like scripts were working for you until recently. That makes me wonder if maybe Wanikani changed their Content Security Policy recently, causing this issue to appear. Or maybe this really isn’t the issue, though I haven’t found anything else that might be.


Which version of Safari are you on? After a quick look-see at the thread I’ve linked previously it appears that another user had a similar problem on Safari 9 but then updated to Safari 11 which seems to have fixed the problem. Maybe that’ll help?

1 Like

Version 13.1, and it seems like that was released a while ago. However, I do have a macOS update pending tonight, maybe that will do something…

1 Like

Even if you haven’t found a solution, I really appreciate that you have gone to this much effort to help :hearts:
I will get my computer to update on the off chance that impacts something :woman_shrugging:

Apparently we need to buy tamper monkey now in order for userscripts to work on Safari on Mac? Please tell me I’m wrong!

I bought mine, sorry to have to tell you that :pensive: Safari went and stopped running my scripts AGAIN, although it seems like most people won’t have that issue :sweat_smile:

For what it’s worth, I use Safari for (almost) everything else, but now use Firefox for WaniKani. My reorder script just stopped working (in Firefox) but I restarted the browser and now it’s back in business.

Hmmm I am glad it has started working again. If you have more issues, or issues with other browsers, drop by and leave a comment. It would be good to know how frequent this is.