[OBSOLETE] Wanikani Override ("ignore answer button")

It turns an incorrect answer to a correct answer when the user clicks on a button. Compared to double check, it’s extremely limited.

Yes it just ignores the answer and asks again at some point.

1 Like

I love this plugin!
I just kind of wish you could choose to ignore the answer even if you’re correct. For example, the answer was “to glance over, to look over” and my answer was “to hand over”, and it was close enough. Even though the meaning is completely different.

The [Double Check] script lets you do that.



I think Firefox may have removed TamperMonkey (at least for me), is there a way to run the script directly? I can go through a few steps manually if necessary.

1 Like

There’s currently a glitch with Firefox where almost all add-ons have been disabled. It looks like somebody let a certificate expire. They’re working on fixing it.


Ew. My Firefox literally just now disabled Tampermonkey. And worse, my ad blocker too…

@SoraR @vapour101 @Belthazar

To fix Firefox add-ons temporarily, go to about:config, search for ‘signatures’, and toggle xpinstall.signatures.required to false.

Just make sure not to leave it disabled after Firefox is fixed.

It’s already been fixed according to their Twitter.
However, the xpinstall.signatures.required option only works in Dev, Nightly and ESR versions, apparently it’s disabled in the standard release.

Also worked for me on the standard Android version, which apparently wasn’t fixed yet at the time I posted above.

It’s been fixed for me now.

Oh yeah, I remember seeing someone say that it wasn’t disabled in the Android version. However, it definitely didn’t work on the standard desktop version for me. Weird that they only removed that from the desktop version.
Regardless, the hotfix seems to be working.

This script is so much love… bye bye typos and such.

1 Like

I kinda of want to install this simply because I have gotten so many wrong already with double Ns because if it type onnanoko おんなのこ it comes up onanoko おんあのこ due to nn just showing as ん… I’d have to type my answer with triple n which I know isn’t the right spelling and that hurts more than helps. Also things like senen せんえん (1000 yen) show as せねん if i spell them correctly in romaji.

Is there a better solution for my problem or should I just use this? or try to force myself in the (bad?) habit of typing an extra n all the time for ん?

That’s a good habit. It’s the correct way to type ん. It’s necessary to make the IME know what you mean to avoid the exact cases you described (せねん vs せんえん, etc.). You can get away without it sometimes, but I’d recommend just getting used to it.


Indeed. It may not be how it’s written in romaji, but it is how it’s written in IMEs.

If you’d still like another option, @Raarz, n’ (that’s n + apostrophe) does the same trick.

1 Like

I’m afraid the latest update rendered this script obsolete… Anyone else having trouble using it? It’s still installed but I can’t use it anymore in my reviews…

I think everyone’s moved on to double check… I only reorder in lessons as well. Reviews are best kept random to enhance memorisation.

Yeah, I don’t reorder but this script allowed me to cancel wrong answers due to typos and stuff… Could you point me towards a working script that does that as well? Thank you so much!

that’s exactly what double check does! here’s the thread if you have trouble finding it [Userscript]: Double-Check (Version 2.x)
I switched to this over override a while ago since doublecheck prevents me from tapping enter twice too fast and inputting a wrong answer when doing reviews quickly.