Most (but not all!) of my scripts stopped working?

Throwing another one of these posts into the void.

I checked the other “my scripts have stopped working” posts, but my problem seems to be less common, since only some (most) of my scripts have stopped working. I can get some of them to work, like WK Override and Pitch Accent, but the ones I use the most, like Heatmap, Reorder, etc, have stopped.

I have script compatibility turned on already (and I’ve tried turning that off and on). I have updated chrome and restarted my computer, updated the open framework, turned off all the scripts and turned them back on individually, disabled and re-enabled Tamper Monkey… Nothing has worked, and at this point, I’m at a loss. Any ideas/help would be appreciated!

1 Like

Much as I hate to say it, I released an update for Open Framework yesterday, so that could be contributing. Try opening the Javascript console (press F12 and click on the Console tab) and post any errors you see there.

The other main thing to do is clear cache. Sometimes the browser’s storage database gets corrupted.

4 Likes

Thanks for the advice! I tried clearing cache first, and that didn’t work :frowning:
When I check the console, I get these errors.

Dashboard

Screen Shot 2022-03-18 at 10.13.29 PM

Loading reviews

Screen Shot 2022-03-18 at 10.14.39 PM

Reviews

Screen Shot 2022-03-18 at 10.16.48 PM

Bumping for visibility. Encountering the same issue as well.

Can you be more specific about what is not working as expected?

1 Like

My sanity 

3 Likes

Apologies for the delay I was in a lecture. Similarly to the original post, I use chrome and this past week a majority of my scripts stopped working. These include Heatmap, Ultimate Timeline, and others. Some scripts still work like Lesson Filter and Stroke Order.

I also tried everything that Silversong had as well when checking older posts pertaining to scripts not working but to no avail. Happy to provide any more information if necessary.

Most likely, clear your cache and everything will start working. Either way, though, if you can open the developer tools (press F12) and click on the Console tab, and report any errors you see there, that would give us a direction to explore.

I did clear cache but had no success, I’ll try again though.

Here is what I see in the console for the Dashboard, Reviews, and Lessons.
Dashboard:


Reviews:

Lessons:

Hope this info is a bit more helpful!

Okay, looks like the same as in another thread. Try this:

For some reason I see nothing under IndexedDB when going to the Application tab. Any idea why that could be the case? Apologies again for all the questions but I really do appreciate the help!

Screen Shot 2022-03-24 at 11.57.49 AM

Typically, that’s due to security. For example, in ‘incognito’ mode, indexeddb is disabled.
So, I’d check what security features you have enabled.

Understood. I’m not using incognito so unsure what else could be blocking this. I’ll poke around and see what I can find but I’m open to suggestions.

1 Like

I had the same issue - I was able to see and deleted the IndexedDB and now it’s working again

2 Likes