Lessons stuck on the the loading screen


#1

I have this weird problem were I want to start doing some lessons but the loading screen shows up and it doesn’t progress any further than that.
so anyone else having this problem ?


#2

It’s fine for me. Do you have any scripts running?


#3

ah yes maybe I should turn them off and try again


#4

I had the same problem with reviews today. It was caused by the incompatibility between the new Firefox version& Greasemonkey that I had installed. After switching it off everything worked fine again. Maybe that’s the case for you as well?


#5

I’m using tampermonkey
I turned it off but I’m still having the same results


#6

Well, if turning everything off hasn’t changed anything maybe tag the staff in a bit


#7

@eyzo44: Scripts can mess with the data that gets stored locally while you’re doing lessons and reviews. Sometimes clearing that out can help clear things up. Which browser are you using? If you switch (temporarily) to another browser, do lessons load up for you?


#8

I’m using firefox 57.0 and I tried it now using edge and it worked just fine


#9

One way to clear out that local storage is to use the developer tools.

Head to WaniKani first, and go to the lessons page. Once you’re there, go to the file menu and go to Tools > Web Developer > Toggle Tools. Once that’s up, you’ll see a panel like the attached screenshot. Open up the storage tab, and you should see some entries under WaniKani web address. You can delete them by hand or delete them all by right clicking on the URL in that panel and hitting “delete_all”.

Hopefully that clears it up — let us know if it doesn’t.


#10

I deleted them all but it still didn’t solve the problem


#13

thank you for the suggestions
I solved the problem by reinstalling the free download manger addon