During leeson page reloads on answer

Hi,
Today it happened again. Sometimes when I tried to do new lessons I face a really weird issue when after learning all new items I’m in review part, each time I type anything the page just reloads and I have to start at the beginning of the lesson (i.e. going over new information, not at the typing section). I happens sometimes and quite randomly.

I’m using Firefox 81.0.1 with some extensions and userscripts (which may be the problem). I just tried on bare-bones safari and it worked but WK with scripts is, well… better.

Anyone ran into similar problem?

Board suggested Problem - Webpage reloads, can't progress in reviews but there wasn’t a solution…

Did you try disabling your userscripts to see if it went away?

Yup, I disabled all scripts (global toggle) in Violentmonkey, refreshed the page and… it worked. I then re-enabled all scripts, refreshed the page and… it’s still working.

This is quite weird.

I don’t know much about webpages, or what could be causing this, but maybe next time it happens try to open the console (F12) and see if there are any errors?

To make that suggestion work, you will have to open the console window (Ctrl + Shift + K for a direct hotkey in Firefox) before the issue happens, click the settings icon in the top right and select “Persist Logs” in the dropdown.
In its default state the log is cleared on any page navigation, including reloads.

Thank you for the suggestion - I’ll try that next time the issue happens ^__^"

@wojtek just so you know, you’re not alone: got the same problem recently. I go through the first batch of lessons, go to the quiz and on entering the first (or maybe second) answer I’m getting thrown back to the lessons I just did.
with “?user-response=[answer I gave]” added to the url
Also using Firefox and scripts in Tampermonkey; though somehow until now it worked just fine and that problem only somehow started at lvl7; might be it only happens w/ new kanji? 'cause i was thrown back when doing the quiz on them before, but new voc worked fine just now.

exactly - it adds this user-response=… URL parameter.

Do you use any particular script?

I tried monitoring it with DevTools but it seems that each time I start lessons with those the problem doesn’t manifest itself.

I got quite an assembly of userscripts by now. ^^’ Though I had most of them already working before that problem came up. The most recent added were Confusion Guesser and Vertical Reviews. Would that match with any of your scripts?
All other scripts I already installed at around lvl5 and didn’t have any problems until now.

Both of those scripts should only run on the review page and not the lesson page, so they cannot be the cause.

I feel like this happens to me sometimes. I think I usually press a little green button at the bottom of the screen when it does (this fixes the problem for me), but it happens pretty rarely, so I’m not sure it’s the same thing.

The problem in my case is that it’s completely random. And possibility of script messing up with it is small as turning it off and on again (any of the scripts, just to eliminate the culprit) makes the page work just fine (same as opening DevTools).

Regarding study section I have quite some scripts enabled: OF, Advanced Context sentence, Lesson Examples Audio, Lesson Hover Details, Item Hoover details, Katakana Madness, Pitch Info, Kanjidamage Mnemonics, Lesson Filter, Niai Similar Kanji, Keisei Phonetic-semantic, User Synonyms 2, OpenFramerowkJLPT.

And also some UserCSS (character background and blurring kanjis/radicals on vocabulary/kanji so I can try to figure out what makes particular character on my own first.

I just remebered that the lesson filter-script get’s also set back. Again happend when the quiz for new lessons started with kanji, but was fine for the second batch with vocab.
I tried to see if the console did log any errors and the first one displayed was

 Uncaught TypeError: n is undefined
    m answerChecker.js:230
    evaluate WaniKani Katakana Madness.user.js:219
    actionsOnAnswerSubmit application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:106
    keysMouseActions application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:106
    dispatch application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:26
    handle application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:25
    trigger application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:26
    trigger application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:26
    each application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:14
    each application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:14
    trigger application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:26
    keysMouseActions application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:106
    dispatch application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:26
    handle application-273914694cfdbbd915852c5164a2de09dddaa47ed9481e7aa83140307d224a52.js:25
    ___hb builder.js:420

So for the next level I’ll try to disable Katakana Madness to see if I still got the problem then. For now I got no kanji left. But I’ll see wether it happens with vocab, too, on the first lessons’ batch.

Oh, this is starting to make sense - because the “randomness” may be happening only when you level-up. I’ll definitely check that. I still have 33 vocab from the current level so at my pace I’ll be able to check it in ~6 days.

mh… had no problem with this when learning new vocab right now.

And no exceptions in the DevConsole? It still working ok for me and I’m still waiting for kanji lessons.

ah… >.< forgot to check that. I’ll have a look at that tomorrow when I do the next lessons. I hope I’ll remember to copy that so I can compare with what’s displayed when it happens again.

So I finally got new lessons (radicals and kanji) and… everything is working just fine. Ehhh… =,=

Same here. ^^ So maybe something lvl7 specific?

Well, I’m fairly certain it was happening with level 6 (and maybe 5). Right now I finished kanji of lvl7 just fine. Reeeally weird.