Issues with android apps?


#1

I feel like this would be really common if other people had this issue, but I can’t find anything in the search…

Recently my android WK app has been giving me “wrong password” errors when I try to login. I thought the app was maybe out of date, but I downloaded a different one with the same exact issue. Strangely, the chrome browser on my phone lets me login no problem, and only the chrome browser. Still, it’s a pain in the butt because the english to jp conversion stuff is barely functional with it and I don’t get notifications for reviews. 

Anybody else have issues with this? I have a galaxy s4. 


#2

There are no official WK apps, so this is probably better addressed to whoever made whichever app you’re using.


#3

I had problems logging in to the android app I have a couple of days ago. It wouldn’t accept my password either. But after a few failed attempts, I tried logging in using my username instead of my e-mail address like i normally do and it worked. So I could log in just fine using my username but it would reject my password if i tried to use my e-mail address. Hope this helps.


#4

I don’t have any reviews right now so I can’t try actually using my app but I can get to the dashboard fine; it’s already logged in actually. I use the old app though, I don’t think you can get it anymore. Sorry I couldn’t be of more help.


#5

Thanks all. I know there’s no official app, but yeah good point, I should contact app makers and let 'em know. The interesting thing is that they all took me to the dashboard OK, just not into the reviews/lessons, which made me think that maybe it was an API change. Just a hunch though.

That being said, just tried the username instead of email trick, RubenImmerix, and it worked like a charm. Maybe they changed the ability to login via email at the API level?

ANYWAYS I can review on my phone easily again so I’m a happy camper. Hopefully this thread is useful to anybody else who runs into that problem.


#6

Hello, in case anyone is taken here with the same issue, it’s because of unwanted extra spaces added to the username/email field. Please double check your credentials.


#7

@duncankeller, instead of opening a new thread, you should be posting to the app developer’s thread:

/t/Client-App-WaniKani-for-Android/6035/1

The problem has already been reported and solved on that thread.