[iOS] Mobile AlliCrab for WaniKani

Eleven hours ago I did my reviews and it seemed to work just fine, the shown number was correct. I left 4 reviews to be done later and now I’m back with the same problem. It should be 32, but despite refreshing, it always tells me 4.

Viet private messaged me and verified that my wrong number came from the API. So I don’t think it’s the app.

Next time this happens can you log directly to the website and cross check with what we are showing you on the review summary page?

I’m also having an issue when worshiping the Mighty Crabgator using the Allicrab app on iPhone. (My favorite way to do reviews)

Everything is working correctly except that the Allicrab interface always shows that I have zero reviews. The website and the other iPhone app I have show the correct number of reviews, but the Allicrab always says “0”, even though it correctly displays my lesson count. I went to far as to uninstall and reinstall, but with no luck.

Thanks for the info.

All the API endpoints cache keys use the latest updated_at timestamp of the all the user stat records. So every time something is completed in reviews, the cache key expires and data gets regenerated.

For the case of the study queue endpoint, we also expire this at the top of the hour, since all the available timestamps are rounded to beginning of the hour, thus counts change at the top of the hour if no updates have happen before then. Therefore the endpoint’s cache is voided when the user stats gets updated (after a completion of a single review item) OR at the beginning of the hour.

There shouldn’t be any holes in this cache key scheme. But maybe we are missing something here…

There are only two hard things in Computer Science: cache invalidation and naming things.


Naming things is the worst.


I did that both times when it happened. My WaniKani review page tells me I have the same number of reviews as indicated on my review timeline. As for the numbers of correct, incorrect reviews, sorry, I don’t know.
Two minutes ago, my new reviews came up, and everything worked just fine…

Happy to report that all numbers matched this morning kind sir!

1 Like

So did mine!

1 Like

If you are having issues using this app during reviews in regards to “Connection Lost”, please view the following thread:

Is anyone else still having trouble with mobile allicrab? I haven’t been able to use it at all the last couple days, after doing 10-15 reviews I start to get the “connection lost” thing after almost every answer I input. Yesterday I managed to get through ten or so reviews and when I got back to the dashboard I had the “0 lessons 0 reviews” problem people mention, and the 10 reviews I had finished hadn’t made it into the system (I was given them again at my laptop later).

I see viet’s post above and have read through recent comments but am not clear if there is any kind of fix going around. Thanks in advance.

The only issue I’m aware of is in connection with WaniKani Double Check. Are you using this script? If you are, can you try disabling it and see if the issue persists?

Just did 25 reviews with WK Double Check turned off, and all is working fine again. Thanks so much!

1 Like

@cplaverty I think the “All Upcoming Reviews” section of the app is wrong. The Reviews on the main page of the app says 53. A direct API call verifies that it’s 53 as does going to the actual reviews page on the site. However, the app saying Upcoming Reviews “Now” is 51. I also looked at the timeline script which correctly showed 53. I thought it might have to do with the new/moved items, but when I do API requests for their specific levels in the API, they show up on the correct level and correctly say that the available_date is in the past. So at least I don’t think the new items are wrong from the API side.

I’ve seen this issue over the last few days, but didn’t dig into it until now. I’ll do reviews later in batches of 10 to see when the numbers get in sync. Maybe that will give a hint about what item is causing the issue.

The app doesn’t handle new or moved items well. It will probably have downloaded the levels the items moved from, but not necessarily the levels the items moved to.

The issue will resolve itself sometime over the next two weeks, but a quicker solution is to purge the internal database. First, kill the app. Open the Settings app and scroll down until you find AlliCrab. Tap that, then under Troubleshooting there’s a slider for Purge Database. Toggle that and restart the app. It should then re-download all data from the API, and hopefully show the correct item count.

From what little hints Viet has given, it sounds like I can fix this properly in the next version of the API, whenever that becomes available.

Done and worked, thanks!

1 Like

@cplaverty How are the fonts for Jitai controlled? The fonts (with the bug fix in the beta) are very different from the ones on the browser script.

In the beta, one of the Jitai fonts didn’t show up in a review. This is on an iPhone 6.

I bundle fonts with the app. The font list currently is:
darts font

I found that sometimes when a particular font is selected for the first time, it takes a moment for the browser to load the font. I haven’t seen it refuse to load at all. When you touched the area where the text should be, did it return to the default font (so you could answer the item)?