Installing Wanikani Open Framework

You have to sort by the “#” column for the Sort column to appear.

Personally, I would have preferred that they keep the Sort column visible, but grayed out with a hover pop-up to tell you that you have to sort by ‘#’ to enable it.

1 Like

Yep, that’s what the problem was. It seems obvious now, but that certainly isn’t an intuitive design choice on their UI.

(A sort column that has tooltip-text explaining why I can’t sort manually when the list is ordered by some other column would have avoided all of this confusion)

Looks like you were updating your post to say the same thing I was writing. Maybe this is cause for an enhancement-request.

1 Like

I think I just got used to use imports and building tools and forgot about the problem of loading some script firsts and race conditions.

@rfindley Maybe another solution would be to provide a piece of code that checks for the existence of the framework and if it’s not there just load the script inserting it into the document? I admit I don’t know how userscript programs work and their limitations.

So yeah, I think in the end the best solution would be to force users to manually set the order of scripts if there’s no other cleaner workaround.

That’s actually (sort of) how I implemented it in my first draft, and there were several problems with it, mostly race conditions like you said. If several scripts happen to run before the Framework, they’d all try to load it, not being aware that the others were already trying to do so. Plus, if the framework is installed, but just not in sequence, then you’d end up with a third copy :scream:

Anyway, there were solutions, of course, but the code required to safely include the framework was just getting bigger and bigger… ugh!

On a side note, I’m going to see how tiny I can make a non-alert-based popup, with a redirect prompt instead of the automatic redirect. If I’m happy with the results, I’ll post it here as another alternative that client scripters can use.

… which reminds me. The alert-and-redirect actually is just client-script code, not Framework code. So scripters have the freedom to come up with nicer solutions and post them here :grin:


I prefer the alert and just saying “screw it” to people whose browsers don’t let them copy from alerts. :wink:

On a related note, it’s a shame it’s not possible to do some kind of require()-like functionality.

Update on the Safari issue I was having: I thought I had the latest version on my system at home, but it turns out I was mistaken. I updated Safari, and now all scripts are working. So for future reference, Safari 9 doesn’t support Open Framework, but Safari 11 does for now.

1 Like

wow a lot of scripts !!

from your list are there any other scripts you would recommend?

All of them :slightly_smiling_face:

I also got WaniKani framework additional after that post


Its not working properly here. It loads fine when i first enter wanikani but when I return to the landing page after a review or a lesson the Open Framework dont load. I`m using Chrome.

What evidence are you looking at to determine whether the framework is running? What scripts are you using it for? Are you seeing any errors in the Javascript console? (press F12 and click on the Console tab)

Because everytime I return to the landing page it says I need the framework to run the ultimate timeline.

Okay. Have you followed the instructions (at the top of this thread) for moving the Open Framework to be the first script to run?

Yes I did.

Ahh… you need to click the ‘#’ column again to sort by ascending order (not descending). Then a Sort column will appear on the right, and you can then move it to be the #1 script (it’s currently the #8 script).

This evening, I’ll see if I can make that more clear in the instructions.

Lol I was really dumb now lmao. Thanks man!
Weirdly enough when I had no reviews left the bug didn’t occur.

No worries… It’s easy to overlook. I’m glad it’s working!

Hey, so I just got the notification to install open framework to use ultimate timeline, I’m using firefox with violentmonkey.
Installed it, dragged it to the top, but now the timeline doesn’t show up at all… i tried reinstalling the script but still doesn’t work.
Am i missing some steps?

The ultimate timeline script started redirecting me here today, even though it’s always worked fine. I’ll probably just disable it, since, ya know, I’d like to be able to get to the dashboard.

It’d be nice if it just opened a new tab instead of not letting you access the dashboard forever until you solve the issue.

Could you post a screen-capture of ViolentMonkey? Maybe I can spot some clues in the screen capture. Also, check the Javascript console for errors (press F12 and click the Console tab).

Have you followed the instructions in the top-post of the thread, specifically sorting the Framework to be in the #1 position?

Not yet. Because I don’t have it at all, which is what was confusing to me, since everything seemed to be fine until today.

Maybe later.

For now, I’m just timelineless.