How can I stop the notifications on my own (wiki) post?

I tried muting it, that didn’t work. I think I tried something else or two before that. I get SO many notifications from that wiki thread about it being linked… ???


I don’t think you can. If someone links to your post you always get a notification.


I was considering requesting it as a feature from Discourse… I can’t remember if I did or not.

I have a few that get linked in almost every welcome thread… Just a checkbox to say “do not notify me of links” would be nice.

I seem to recall it going the way of all functionality requests from the discourse dev team: “We’re not going to do anything about it.”

(Or I searched and found a pre-existing thread to post in/read.)


I wonder if there’s a way to transfer ownership of the thread… :confused:

I don’t believe there is… :’/

Kumirei will be the death of me. lol


In my case it’s gojarappe.
She’s offered to take the link out of her post, but I told her not to worry about it - because it is helpful and that’s what it’s for…

If you really want it to stop I could post an identical thread and we could ask to have that pinned instead. I check my notifications enough that it wouldn’t bother me


What if you muted the introductions category? Would that stop notifications at least for welcomes on intros posted there? I know sometimes they aren’t posted there, though.


just add “POLL” to the title


Probably depends on the perceived value of the request… but seanblue and I managed to get ruby tags and the ‘lang’ attribute whitelisted. It took a couple rounds of inquiry, though.


Yeah, I remember that.

But that wasn’t just end-user options… ヽ(^。^)ノ

There was something about maybe looking at it again in 6 months (about a month to a month and a half ago?)… So we’ve only got 4-5 months to wait before they’ll even look at the subject.

I think one of the Dev’s was kind of for it, but the lead totally wasn’t.

I don’t see any topic or post from you on the subject. I also couldn’t find it by searching. :thinking:

Strange… Maybe it was a similar feature. I do recall it was SOMETHING about a setting that disappeared/a check box of some sort in settings…

… I’m pretty sure I didn’t post (I think it was locked, or for locked as I was reading it.)

Edit: I’m searching for it now… Pretty sure it was in the feature section…

EDIT 2: Oh, I found what I posted on at least - the return of reply-jump.

I did make a post now, on a thread that was approximately a year old.

There is one other thread (at least) on the subject, kind of, (the guy is also getting them in his email and I think just wants to block the email notifications, but I used his screenshot as an example)… from January…

So… There’s that.

My post is here.

EDIT: @Shiawase, if you’d like to support the suggestion, I recommend making an account at and agreeing with me there (with your own screenshot/reasons, too). The more people that talk about it, it seems, the more likely it gets considered.

Hey, @Shiawase, good news - while we might not be able to turn off notifications for links, one of the devs at meta.discourse proposed a solution:

So, in that case… I guess you would want to ask @anon20839864?

I think I changed my mind about it in my case… because I’ve kind of gotten used to it. But I will keep this in mind… if I ever change it.

1 Like

Thanks everyone. @anon20839864 Is this possible?

@Kumirei that’s way too much to ask of you.

Suddenly @WaniMekani awakes from its slumber…


@Shiawase Unfortunately, I’m not sure how to do this if it is possible. Maybe @oldbonsai would know?

1 Like

Well, it sounds like you tried the “muted” notification controls, and that’s where I’d look. Maybe check your notification settings (Account > Preferences > Notifications) and see if changing those tunes it down a little.

Otherwise, yeah, reach out to the Discourse team on and see if it’s a feature that’s missing/needed/should be revised.

1 Like