Help mastering Microsoft IME settings?


#1

I mean this thing:


Is there a way to disable the space bar menu so I can just type and the kanji appear without having to hit space and enter?
Also how can I disable this box?:
Cap56345354786ture
If you’re confused, it appears when you type without having clicked into a textbox. I need the box to not show up at all for reasons, because it stops me from typing into whatever I want.


#2

You can’t - that’s just how it works. Even Japanese people push space and enter. Besides, do you really want it to always choose the first kanji in the list?

I confess I have no idea what that box is…


#3

Because a lot of kanji have the same sounds, there’s not really a way for the IME to know which kanji you are wanting to write without you telling it. And because the Japanese written language often doesn’t use the space bar the way English does, with space between words, the space bar is usually used to tab through the kanji options when typing. You should be able to use the tab button on the keyboard for the same purpose, then press enter to select the kanji. Unfortunately, like Belthazar says, there’s not really a way around it.

I’m not familiar with this either. Nothing I can see in the advanced settings is for that and I haven’t been able to duplicate it. When I don’t have a textbox selected, nothing happens when I try to type. Can you show screenshots of each of the advanced settings tabs?


#4

I’ve only really managed to have the box show in two places. Once while using ‘chatterino’ (a twitch tv program) while trying to type japanese into the chat, and again on this website, trying to type using kana input: http://www.e-typing.ne.jp/acsp/fm/practice/app/jsa_kana/typing.asp?t=skillup.tanbun.fujitsu_pc.1
It also only seems to show using Edge, not on my other browser, Chrome. It shows up in the top left corner.


#5

Hmm. I wasn’t able to duplicate it with the website you linked to, the screen just flashed at me when I tried to input anything but the key it wanted me to, even when I clicked away and made sure nothing was selected as a textbox.

Regarding the e-typing site, though, are you using an English keyboard or do you have a kana keyboard for it? The only thing I can think of is that if you’re using an English keyboard, there’s a conflict between the IME and the website because one is trying to interpret romaji input and the other is just looking for a specific key press.


#6

I have an english keyboard, but I’m trying to practise the kana input so I have it set it to kana input in the IME settings.


#7

Okay. I was finally able to duplicate it. I’m not sure what caused it, but I typed in a word, clicked the green arrow to ‘finalize string’ and the box disappeared and I haven’t been able to make it reappear.

As an aside, the keyboard that website uses doesn’t map very well to an English keyboard (there are at least two keys that don’t seem to correlate to an existing key on mine, anyway), and I don’t think you need to have the IME set to kana input to use it, since it’s just looking for the correct key placement, not the actual input you’re giving it. If you haven’t already done what I did above, you might try just turning off the kana input on the IME and see if that fixes the issue first.


#8

I think if the IME doesn’t really see a text box or something similar that it knows how to type in (because it’s a game or whatever), it will make a fake text box to stage your input.


#9

Don’t do kana input, unless you’re playing some weird sort of memory game. Japanese people use romaji input too.


#10

I guess you could say I’m playing a weird memory game :smile:
But it’s also because I think it would be faster because you’re cutting out the time spent typing vowels after the consonants. It’s like a mix between giving myself a challenge and learning to type japanese faster.