"Guard" Character not showing

こんばんは、

While doing my reviews I noticed that one of the radicals does not show up.
As you can see in the included screenshot, it does show it in the html when i inspect the element in the console.
It only happened with that specific character and reloading did not solve the problem. It might just be a css bug or my computer acting strange, however, since it does show the character in the console, you would think it should be able to render it without a problem…

Just figured I’d create a lowprio bugreport :wink:

Does it show on the item page?

https://www.wanikani.com/radicals/guard

Browser/OS version?

@alexbeldan No it doesn’t, all others radicals, and kanjis which use this specific radical do show though… Which kinda makes it weird :smiley:

@plantron Chrome / Windows 10

Hmm… interesting. That’s not even one of the WK-invented radicals. Can you see the character in the Element Inspector if you right-click where it should be and click Inspect Element?

Yeah, the screenshot I included actually features the character in the inspector on the right side ^^, which makes me think it might be a styling bug somehow.

Normally, Chrome has ‘Computed Style’ tab that can be useful for stuff like this. I don’t see it available in your screenshot. It would tell you which font is being selected, then you could type that character in that font in another text editor to see if it’s a font corruption issue.

If you edit the character and change it to something else, I assume it appears properly?

Have you tried turning off scripts yet?

[edit: by the way, I’m also on Chrome / Win10, and it works fine, so most likely not a WK bug]

Since I’m finally home I could take another look. Seems like this character is the only character which uses this weird font o_o, all the others use the default “Meiryo” font. It doesn’t matter if I change the font family in the inspector though. I wonder why it uses this specific font for only this character.

Edit: I also don’t see it at the installed fonts on my computer.

Not a problem here (Firefox on Ubuntu)

1 Like

you just wanted to show off your sick burn!

3 Likes

[oops… clicked wrong reply button]
@neicul,

I was surprised to find that mine also renders with a one-off font:
Microsoft JhengHei UI
[Note: I’m on Chrome / Win10]
[edit: for some reason, I’m having trouble with WK server at the moment, and can’t paste a screenshot]

Here’s the download link for the font:
https://www.download-free-fonts.com/details/61255/microsoft-jhenghei

To me this radical has never looked like a guard. What kind of guard stands with legs like that? To me it looks like an alien with antennae on the head and one big eye. This alien is from the planet Sassy, that’s why she’s standing like “Check out this body, yo! I worked out before visiting your planet. I know my body is just one big eye with antennae but still!”

A sexy one who undresses in the moonlight then plays darts, apparently.

1 Like

Oh! Maybe she looks like Giada a little bit?

1 Like

I don’t know. For some reason I can only remember what a small part of her body looks like.

relatively

1 Like

Mamma mia! 

1 Like

Installed the font and rebooted but it’s still not being rendered correctly :’)
Thanks for the help so far though. I do wonder why this radical seems to be using a different font from the others, and also where it pulls the font from as I don’t see it installed on my system.

Edit:
Looked at the page in Firefox and it’s not showing the character even in the HTML. When I mouse over the font being used in the style tab, it does show a correct font though. Check out the screenshot to see what I mean.

Edit2:
When I select the character (blank space), copy it and then paste it in notepad, it shows the character as it should

So she’s standing with her legs like this, this is my “guard” radical from now on

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.