Enter Key No Longer Works in Reviews

At all. Had to do my reviews on the iPad. Firefox Developer/Mac Monterey.

Is this a new feature? Is there now another key to use for submitting answers?

11 Likes

Same here, except it’s not just the enter key, clicking the arrow also does nothing. Looks like reviews are just broken all of a sudden?

// Edit:
Looks like it was the “Wanikani Double-Check Gart-Temp-Fix” extension causing it for me, works fine without it.

11 Likes

Yeah, somehow the double-check (full version or the gart-temp-fix) Broke between 8am est and now. If you disable those it should work

1 Like

I am not using double-check. Or any other script. I usually do my reviews in the Tsurukame, but only had one to do and figured I would get it done on the Mac. I think WK now uses the old WordStar WASD for arrow keys…but even WordStar used the Enter key.

yeah doesnt work for me either!

I’m also getting an error. Devtools tell me the script problem is a failure here:

Error invoking action "click->quiz-input#submitAnswer"

TypeError: Cannot read properties of undefined (reading 'trim')
    at normalizeResponse (response_helpers-cce9818c8519e5eaa3b63a7d7a7a3634da1853dfeb5acf1ed2459b12c2340a9c.js:1:121)
    at AnswerChecker.evaluate (answer_checker-e0f227f20b32465b042fea949c7639be7f2344f9a71499e6d82ff3d39904b7d1.js:1:3248)
    at t.new_submit_handler [as submitAnswer] (userscript.html?name=Wanikani%2520Double-Check.user.js&id=4a76ca62-e318-47c8-b08a-3e89798a1d4e:524:47)
    at d.invokeWithEvent (stimulus.min-25bc004b0c72612dc2753d7fa8f87f1aa6a877adce8bb2ffee45fb68e25f6116.js:1:7065)
    at d.handleEvent (stimulus.min-25bc004b0c72612dc2753d7fa8f87f1aa6a877adce8bb2ffee45fb68e25f6116.js:1:6454)
    at e.handleEvent (stimulus.min-25bc004b0c72612dc2753d7fa8f87f1aa6a877adce8bb2ffee45fb68e25f6116.js:1:3879)
    at HTMLButtonElement.object (review:6:29544)
    at HTMLButtonElement.nrWrapper (review:6:28155)
    at t.handleKeyDown (quiz_input_controller-ed3f7f9cd99351daa8876c30f70d47126a0e27c94e3ef710bad23260c1126cc3.js:1:2467)
    at HTMLInputElement.nrWrapper (review:6:28155)
1 Like

Um, I am not a programmer. Am I supposed to put this code somewhere in order to be able to press the Enter key?

1 Like

Yeah, double check breaks it for me too

1 Like

No scripts here (beyond a few overview tweaks); enter works fine for reviews (Windows 10 Chrome, Firefox, Edge).

Enter now works randomly. Sometimes it works, sometimes it doesn’t. It works ok in Safari, but the ten-second page WK page refresh makes it impossible to use that browser.
I have no scripts installed anymore, so that’s not the problem here.

It isn’t working for me either, I’m glad I checked here.

1 Like

Zero reaction on enter or clicking the arrow manually. Just no reaction at all. I have scripts on, including auto commit, who also doesn’t work.

1 Like

So I have WKOF, Double Check, Detailed SRS Popups, and Do You Even Kana. Disabling everything but WKOF and Detailed SRS seems to resolve the issue for me. It’s not just Double Check causing the problem, because disabling that but leaving Do You Even Kana on I still get the issue. I don’t think Detailed SRS Popups is doing anything though.

I was just experiencing this issue. Based on this thread I tried disabling Double Check and that solved it for me.

But possibly there are a few other add-ons which are also relying on whatever in the background is causing this and maybe I don’t have those particular ones.

Seems WK push an update that broke some scripts. I’ve made a temp-fix for Double Check that seems to be working for people. If anyone’s desperate:

(be sure to expand or click-through the quote-box, it doesn’t format the code block properly otherwise)

3 Likes

Replace line (in the current version is line 523)

answer_check = answer_checker.evaluate(qtype, answer, subject, synonyms);

with

answer_check = answer_checker.evaluate({
    questionType: qtype, response: answer, item: subject, userSynonyms: synonyms
});

double checker will work again

FYI, there was a change on WK today that caused Double-Check to break. I posted an update about 15min ago.

I don’t know if this is related to the Enter key thing… I just saw that the conversation shifted to Double-Check, so I figured I’d follow up on that part.

16 Likes

For people having this issue, instead of replacing the code as mentioned above (and in another thread), just go to the TamperMonkey page and reinstall the script. It’s been updated, but the version number hasn’t changed, so TamperMonkey won’t automatically update it for you.

7 Likes

Yep, it worked after I disabled the script

It worked… I just updated it “manually”
Usually Tampermonkey asks you before updating it by itself; but since it didn’t you have to click on the date the userscript was last updated in the column “last updated”.

3 Likes