Audio Echoing in Review

Are anyone else’s reviews sounding like a demonic echo chamber? On vocab, my audio has been playing 2-3 times with varying start delays. I restarted my session, browser, and computer. I’ve got scripts running, but none of them fiddle with the audio as far I know.

22 Likes

Maybe it is the Double-Check script? There is already an updated version, but it’s not yet uploaded to Greasy Fork.

EDIT: The updated script is on Greasy Fork. Version 2.2.23 should fix most of the problems (but there is still a known problem in this version: in Lightning Mode, the vocab audio does not autoplay).

3 Likes

I’m also having this issue, and it is, in fact, the Double Check script. Anyone has a fix for it yet?

Edit: Just now read you saying it’s been updated. I’ll try to put in the new code.

1 Like

If that’s the case, then yes. When I tried to do a search, mentions of it didn’t come up. I’m honestly confused how you figured this out

Oh just updated by pasting the code myself but now no audio plays at all. I’ve checked that auto audio is still turned on. Any ideas what might be up?

It might be related to this:

Seems like the audio player just got updated, and some scripts might not have been updated to work with the changes.

2 Likes

Yes, this is the reason.

The new version should however already work with these changes, but @Haryor says that it doesn’t. Strange.

1 Like

I have just tested it, and for me autoplay works. Have you tried disabling all other scripts except Open Framework?

Fyi, I’ve posted the updated Double-Check code to greasyfork.

There will be another update later today to fix one remaining minor issue.

5 Likes

I’ve tried disabling all other extensions except for Open Framework and Double-Check and the no audio at all problem remained. After disabling Double-Check it went away. I’ll try using the now updated code though, just in case there was something wrong with my pasted code. Though the script was otherwise working as expected after pasting.

2 Likes

Post screen-shots of your Double-Check settings, and I’ll test with those settings.

Also… while this is obvious, I’ll repeat it here since it has happened before: remember that you should only get audio for vocabulary, not kanji. When focusing on audio issues, it’s easy to overlook when audio shouldn’t be there. :slight_smile:

1 Like

Just Koichi doing his occasional cult rituals

7 Likes

Just to confirm, I also reproduce the problem when both Double-Check and Open Framework are enabled. Enabling just one or the other (or neither) seems to work fine, but not both together.

Here are my Double-Check settings:





1 Like

Oops, I replied to the wrong post, but see above

I had the echo problem as well, so I updated to Double-Check version 2.2.23 today.

Now the sound seems be completely missing, but I can get it to play manually by pushing the audio “speaker” button.

I also run Open Framework which is used by multiple extensions I have, so would ideal if it would work with both.

Much love to you guys producing these awesome extensions without which Wani-Kani wouldn’t be the same!

3 Likes

The ‘no audio’ issue seems to only exist while lightning mode is enabled.

1 Like

:point_right: [ v2.2.24 ] - Fixed various audio issues. Added new setting ‘Show corrected answer’.

@Jthiesen @ianchamberlain @jc04tu @Haryor

10 Likes

Thank you very much. Was in the middle of 50 reviews and noticed the sound didn’t play after typing in several answers in a row.

Will test in a few hours once I have new reviews available and pass any info to you.

Thank you rfindley!
:slight_smile:

2 Likes

Thank you!

Thank very much for the quick updates. Will give this a test when my next set of reviews comes around.