AnkiDroid Problem


#1

Hi guys!

Recently I started using anki and dowloaded the decks that hinekidori shared in the link below
https://community.wanikani.com/t/some-supplemental-material/8121.

So now I am using the complete 10k, the genki complete vocabulary and another deck that I created.

I had no problems using the anki desktop, but when I tried to sync it with my cell phone the AnkiDroid app crashed and reported this error

So I clicked in options and I have 4 possibilities. I tried the first one (retry opening) and the third one (full sync from server)

However everytime the app crashes again with the same error.
I have already looked up for solutions but I didn’t find any.

I don’t know if this is the right place to ask for advice, but maybe one of you could have already encountered this error and somehow solved it.
It would help me a lot if I could use anki in my commuttes

Thanks in advance!


#2

Sounds like one (or more) of the fields on one (or more) of your cards is too long.
All the data is stored in a database, and it sounds like Android databases have a smaller max-size (length) than PC. So a super long card could work fine on PC, but be too long for Android.


#3

Thanks for the reply!

So basically i will have to search manually in the database and delete those cards?
Probably will be one card of the sentence type

Or I will have to give up on the 10k complete deck


#4

Are you trying to sync all the media from that deck on to Ankidroid?


#5

I guess so

I don’t know if it is possible to sync only one deck


#6

If you’re not interested in sentences at all, I believe you can delete that portion from the card type, which deletes all the associated data.
Or, you could export the data to csv (I think Anki can do this… can’t it), import into excel, and work some magic to find the long sentences.


#7

I never did this. But someone told me to sync the deck, but not the media, and then just manually transfer the media over onto your android device.


#8

In fact, I am interested in the sentences as well, but if there is no other way, I would study them separately


#9

Thanks!

I will have a look on this and will try to sync the deck


#10

Can you get an older version APK? It seems to be a problem with the latest update.


#11

Excel import would be the quickest and easiest way to do this.


#12

I had this problem on my android smart phone too. My conclusion was that my phone’s internal memory is not big enough to hold the database and the updates at the same time.

Because Android and Mac OS/X are not friendly to each other, I used a “wifi file transfer pro” app (on android) to view the phone’s file system on my Mac OS/X. Anki data is in the phone’s “internal storage”. On my phone, the Anki folder is called “/storage/emulated/0/AnkiDroid/?”

I deleted the old database from the android phone and restarted the sync.

What I think happens is that Ankidroid downloads the new information before it updates the database. Then it deletes the new information because it is now in the database.

As @alexbeldan pointed out earlier, turning off media file synchronisation would help. Media file changes take up a lot of space. You can copy them at a different time.

You could also consider getting a phone with more internal storage.

As a comment, Ankidroid would be a lot better if it allowed the data to be stored on my SD card, which is considerably bigger than my internal storage.


#13

I think I recall a similar error myself - you’re trying to sync too many cards/decks at once. If you can manually set to sync only one major set of cards at a time, it should work (better) - ie: just G-Anki or just Core 10k.


#14

big thank you guys!

Tomorrow i will try to do these steps. I don`t know how to set to sync only one deck or to not sync the media files or to excel import, but i will look for it on google. You already helped me a lot.

@wunderbunny yes, as a matter of fact my internal storage is quite full, I guess it is time to delete fire emblem heroes :pensive:
I have a 64gb sd card and it has 30gb of free space. I don’t know why it doesn’t accept to store on the SD card, it is a pity

once again, thank you guys!


#15

Ankidroid
. Settings
. “AnkiDroid General Settings”
. Uncheck “Fetch media on sync”
. Uncheck “Automatic synchronization”

It synchronises the entire collection of decks. To separate, you would have to create separate Anki accounts. Then switch between accounts. I don’t know what will happen if you are switching between such large databases. I suspect it will reload the whole database every time you switch because your phone only maintains one account at a time.

to be honest, I don’t think this app works for very large databases like the one you are using. I would stick with the desktop version for large Anki databases.


#16

I have core 6k kana (plaintext), and all of G-anki, and my phone handles it fine… However I think I downloaded and synced that content when my phone was relatively new and mostly empty…

I don’t believe @maniguigs needs separate accounts…


#17

How big is your phone storage? Mine is only 16Gb. I wasn’t able to keep the large vocab database. I had to delete mine.

Ankidroid was not designed to use alternate storage.

No matter what storage we have, if the phone is crowded with too many apps / data, it’s going to lead to problems.


#18

I have 16 gb too!

I tried to change the settings and unchecked “Fetch media on sync” and it didn’t work.

My last attemp was to delete the 10k deck using the anki desktop and then synchronized again with anki droid.
Turns out that I got the same error, so at least it doesn’t have to do with space.

I don’t want to delete the genki deck because I would lose all my progress

Once again, thanks for the help!

my last hope is to install an older version as @polv suggested


#19

I’ve also used some of those Ankidecks.

10k media (don’t sync it)
Sync will fail if you’re trying to sync the 10k media. Just sync the deck itself without media and copy the media to your device manually and you’ll have no issues with that (I use the 10k deck on both Ankidroid and Anki for PC and had to do this).

String length database error
The string length error, for me was caused by Hinekidori’s verb conjugation deck. I simply had to give up on using that. So either the Genki vocab or your custom deck is causing that error.

As a side note, do you specifically need the Genki vocab deck if you’re using the 10k? Most if not all of the vocab will be in the 10k.


#20

I always uncheck that for a different reason - media takes too long a time to sync. Instead, I manually copy media folder to phone memory.

You can export the deck to *.apkg and the progress will be backed up.