Wanikani Reorder Ultimate [old version, not working]

same problem here, let me know if you find a solution

What’s the best version to use for mobile + Violentmonkey? I had one kind of working (mostly broken but it did what i wanted it to do) on my old phone but I haven’t been able to find the same one since then.

@marikaefer @Mars15,
From a dozen or so posts above:

:point_right: [ v2.2.4 ]

This version was a patch I made to fix Reorder after some Wanikani changes. Note that it requires you to [install Open Framework] script. (Be sure to read the instructions if you don’t already have Open Framework installed)

1 Like

Worked like a charm. Thank you so very much for all you do for this community!

1 Like

@xMunch, I’m not sure if you’re still around maintaning this script. I just thought about suggesting something.

Big piles of reviews are a big problem and people have a hard time coming back.

I wonder if ordering by SRS level would ever be something to take into consideration. I believe it would help people with huge piles of reviews to get back, as they would be able to go level by level (SRS wise). If not, there’s always the ordering by WK levels so :slight_smile:


there is a script for that:


You and @Towe are beautiful human beings. I’ve been swamped with work recently, so it’s nice being able to target my apprentice level items and make sure that I can at least get to them even if I’m unable to address everything else in my queue.

1 Like

How do I disable or uninstall this script? It won’t let me do my reviews. Thanks!

Well if it doesn’t let you do your reviews then something is definitely wrong, maybe you can provide a more detailed bug report so that people can figure out what’s wrong? Like are you getting an error message or is it crashing or…?

To disable a script you click the button of your script manager in the taskbar and then you can switch it off.

If I can find the button, I will disable it. I already sent a help message, and that’s how I know it is the script problem.

I installed version 2.1.0 for reviews.I’m using Chrome and now I can’t do my reviews. I can put the answer for the first one, but I can’t get to the next item.

This is what I get on the screen: WKU::Please Wait::Currently updating UID list… 100%
WKU::Please Wait::Currently updating UID list… 0%

Obviously, I don’t know what I’m doing. Can you help? Thanks.

Thank you! The directions for fixing my script problem was clear and easy, and better yet, it worked. Thank you!

I just installed the script, but nothing seems to have changed. Where would I go to reorder things etc.? I have installed other reorder scripts previously, but have since deactivated them to install this version. Thanks.

You do it in reviews/lessons

I recently installed this script to help manage a massive review backlog, but I can’t seem to get it to work properly. I’m having the same issue as previous users, getting the message “WKU::Please Wait::Currently updating UID list… 100%” without the interface ever actually appearing. I’m using TamperMonkey and have WaniKani Open Framework installed and set to run first. Is there anything else that could be causing it?


A dozen or so posts up, (i.e. [here]), there’s a modified version that fixes the script after some changes that Wanikani made. To use it, you’ll also have to install the Open Framework ([here]… be sure to read the directions!).

1 Like

For some reason since I updated the script to this version today, it froze the website everytime I tried to do reviews. I deactivated it, refreshed the site and that did the trick, but… :confused: Lessons seem to be unaffected by this though, the script works just fine there.

1 Like

This script isn’t working anymore for me since today’s update.

Looked fine to me, so please post any info about what’s happening. Also, post any errors in the Javascript console (press F12 and click on the Console tab)

I got this: