Wanikani Reorder Ultimate [old version, not working]

Using this script for a little over 2 months now, I’ve completely worked my way back up. I owe you one, xMunch.

rodent said... I got this error with the reorder script, and was asked to paste the error here. I'm using version 2.0.19 of the reorder script, Mac OS X 10.10.5, Firefox 41.0.2.

This has worked for me with this same configuration before.

TypeError: item is null
utilities.toUID@file:///Users/username/Library/Application%20Support/Firefox/Profiles/gy90e8t9.default/gm_scripts/Wanikani_Reorder_Ultimate_2_BETA/WKU.user.js:597:3 setup.update.apply/<@file:///Users/username/Library/Application%20Support/Firefox/Profiles/gy90e8t9.default/gm_scripts/Wanikani_Reorder_Ultimate_2_BETA/WKU.user.js:112:36 .each@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:14:14384 setup.update.apply@file:///Users/username/Library/Application%20Support/Firefox/Profiles/gy90e8t9.default/gm_scripts/Wanikani_Reorder_Ultimate_2_BETA/WKU.user.js:110:5 setup.ui.create@file:///Users/username/Library/Application%20Support/Firefox/Profiles/gy90e8t9.default/gm_scripts/Wanikani_Reorder_Ultimate_2_BETA/WKU.user.js:178:4 setup.init@file:///Users/username/Library/Application%20Support/Firefox/Profiles/gy90e8t9.default/gm_scripts/Wanikani_Reorder_Ultimate_2_BETA/WKU.user.js:97:5 @file:///Users/username/Library/Application%20Support/Firefox/Profiles/gy90e8t9.default/gm_scripts/Wanikani_Reorder_Ultimate_2_BETA/WKU.user.js:628:2 G.event.dispatch@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:15:4794 G.event.add/s@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:15:758 G.event.trigger@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:15:3361 .trigger/<@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:15:11196 .each@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:14:14384 G.prototype.each@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:14:11103 .trigger@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:15:11175 $.fn[ev]@file:///Users/username/Library/Application%20Support/Firefox/Profiles/gy90e8t9.default/gm_scripts/Wanikani_Reorder_Ultimate_2_BETA/WKU.user.js:10:108 D/<@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:14:8497 G.Callbacks/d@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:14:16829 G.Callbacks/f.fireWith@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:14:17614 I/s@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:14:6514 G.fx.tick@https://cdn.wanikani.com/assets/v03/lesson/application-a7b68c90e2aa16977d6ba93acd1fdcbe.js:22:11979

Logs:
WKU Init()
Checking for UID updates
Applying UID levels


 Thanks, should be fixed... I hope.
xMunch said...  Thanks, should be fixed... I hope.
 Thanks for the quick turnaround. I just noticed Firefox telling me this script auto-updated.

I won't be able to tell you whether it is actually fixed or not, since the problem didn't happen consistently to begin with. But if the stack trace helped you find a real issue, then it's good to hear.

I must be a huge idiot because when I try to install this script, chrome just says I can’t install from this website.

Any help?

robjapan said... I must be a huge idiot because when I try to install this script, chrome just says I can't install from this website.

Any help?
 Never seen this error before.
robjapan said... I must be a huge idiot because when I try to install this script, chrome just says I can't install from this website.

Any help?
 do you have tampermonkey installed?
tutorial on how to use scripts here: /t/How-to-Install-Userscripts/8319/1

sorry if you do in fact know how to use scripts, but its best to start with the basics when troubleshooting
ShotgunLagoon said...
robjapan said... I must be a huge idiot because when I try to install this script, chrome just says I can't install from this website.

Any help?
 do you have tampermonkey installed?
tutorial on how to use scripts here: /t/How-to-Install-Userscripts/8319/1

sorry if you do in fact know how to use scripts, but its best to start with the basics when troubleshooting
 Awesome thanks, with tampermonkey it installed perfectly and works great!

Thank you!!

I don’t understand how I add this to WaniKani. I’ve tried clicking the link and I just get a download of the script you made (sorry if that’s the wrong terminology, I don’t know much about coding). How do I get around to using this. Thanks.

Edit: just looked through recent posts and realised that I need Tampermonkey, but I’ve had little success trying to use that in the past as well so wish me luck. Any advice would be appreciated.

SUCCESS!!!

This script is getting a little buggy because of the shuffling Kouichi does with the kanji / levels. Any chance of updating uidLevels to reflect the new changes. (Or a quick share of how to update the list ourselves.)

Thanks,

Edit: I am not sure if the script was updated, or if my script installations were messed up. However, deleting and reinstalling the userscript caused a reload of the kanji and everything appears to have fixed itself. Things are also now sorting in the correct order again.

Zageron said... This script is getting a little buggy because of the shuffling Kouichi does with the kanji / levels. Any chance of updating uidLevels to reflect the new changes. (Or a quick share of how to update the list ourselves.)

Thanks,

Edit: I am not sure if the script was updated, or if my script installations were messed up. However, deleting and reinstalling the userscript caused a reload of the kanji and everything appears to have fixed itself. Things are also now sorting in the correct order again.

 Mmmmm, the script updates its "database" when it finds that it is out of date.  I don't think it detects level changes though... It's been a while since I looked at the code.

I assume it would help to just delete the existing database via the javascript console:
    $.jStorage.deleteKey(‘uids’)

But it’s been a while since I’ve looked at the code, too.

rfindley said... I assume it would help to just delete the existing database via the javascript console:
    $.jStorage.deleteKey('uids')

But it's been a while since I've looked at the code, too.
 Yeah, it would refetch the data since it doesn't exist.   I could add something to check if data has changed then refetch all data but... idk...

Since this thread was in top posts, I went and checked out this script. I like it more than the other one I was using - "WaniKani Lesson Ordering II"
Thanks everyone! My WaniKani experience is even more customized now.

I’d been using this script to get the kanji and radicals out of the way but it’s gotten really buggy. Now if it’s turned on, whether the answer is correct/incorrect the bar just shakes. 

So, for example, I had the vocab word 靴 come up, but when I put くつ the bar shook, and then when it said to put in the meaning and I wrote ‘shoes’ it also shook. (I made sure that I wasn’t switching them or something). 

What version of the script are you using? Reoder 2
Were you using the script for lessons or reviews: reviews
What browser/operating system were you using? Chrome/Mac OS 10.11.1
What seems to be the problem? The bar shakes instead of just taking my answer. 

Steps to reproduce this:
Post your settings*:



I also tried deleting and re-installing. 

Edit: -_____- apparently it fixed itself. I had a window open where I was doing lessons (and the script was active) and once I got rid of the window it stopped bugging. 

mahum said... I'd been using this script to get the kanji and radicals out of the way but it's gotten really buggy. Now if it's turned on, whether the answer is correct/incorrect the bar just shakes. 

So, for example, I had the vocab word 靴 come up, but when I put くつ the bar shook, and then when it said to put in the meaning and I wrote 'shoes' it also shook. (I made sure that I wasn't switching them or something). 

What version of the script are you using? Reoder 2
Were you using the script for lessons or reviews: reviews
What browser/operating system were you using? Chrome/Mac OS 10.11.1
What seems to be the problem? The bar shakes instead of just taking my answer. 

Steps to reproduce this:
Post your settings*:



I also tried deleting and re-installing. 

 Sometimes I’ve noticed that when you leave 2 windows open it messes with the script.  Lets say you started a review and you just forgot about it and opened another tab to start reviews it would do what you said every time.

Though, in this case I don’t believe that is the problem.  I don’t really know why else this would happen though.
xMunch said... Sometimes I've noticed that when you leave 2 windows open it messes with the script.  Lets say you started a review and you just forgot about it and opened another tab to start reviews it would do what you said every time.

Though, in this case I don't believe that is the problem.  I don't really know why else this would happen though.
If it happens again i'll let you know.  :]
Thanks for making the script. Sometimes I use it to do the reviews in level order so I can build up my enthusiasm for when I get to the newer material and get it all wrong. :P XD
mahum said...
xMunch said... Sometimes I've noticed that when you leave 2 windows open it messes with the script.  Lets say you started a review and you just forgot about it and opened another tab to start reviews it would do what you said every time.

Though, in this case I don't believe that is the problem.  I don't really know why else this would happen though.
If it happens again i'll let you know.  :]
Thanks for making the script. Sometimes I use it to do the reviews in level order so I can build up my enthusiasm for when I get to the newer material and get it all wrong. :P XD
 I believe it will always bug out when you have two windows open because they fight back and forth to set the question type[reading/meaning].
xMunch said...
mahum said...
xMunch said... Sometimes I've noticed that when you leave 2 windows open it messes with the script.  Lets say you started a review and you just forgot about it and opened another tab to start reviews it would do what you said every time.

Though, in this case I don't believe that is the problem.  I don't really know why else this would happen though.
If it happens again i'll let you know.  :]
Thanks for making the script. Sometimes I use it to do the reviews in level order so I can build up my enthusiasm for when I get to the newer material and get it all wrong. :P XD
 I believe it will always bug out when you have two windows open because they fight back and forth to set the question type[reading/meaning].
I've never had two of the same type of window open. Right now it was one lessons window, one reviews.  
mahum said...
xMunch said...
mahum said...
xMunch said... Sometimes I've noticed that when you leave 2 windows open it messes with the script.  Lets say you started a review and you just forgot about it and opened another tab to start reviews it would do what you said every time.

Though, in this case I don't believe that is the problem.  I don't really know why else this would happen though.
If it happens again i'll let you know.  :]
Thanks for making the script. Sometimes I use it to do the reviews in level order so I can build up my enthusiasm for when I get to the newer material and get it all wrong. :P XD
 I believe it will always bug out when you have two windows open because they fight back and forth to set the question type[reading/meaning].
I've never had two of the same type of window open. Right now it was one lessons window, one reviews.  
 Well, it may be both,  I've never had lessons and reviews up at the same time.  Just try not to have two sessions going at once.