Wanikani is literally unusable without an undo button

I’ve been using the usercripts for so long, I forgot how awful it is not having the undo button. The amount of times I get something wrong because the meaning was phrased differently than I thought, or because I got a typo in the kana input is absolutely infuriating.

Recently flaming durtles stopped working for me, and now I’m left with no way of reviewing with usercripts on my phone, which honestly makes it so much of a hassle now.

I’m willing to go on a limb and say that the majority of users would be really glad to have an undo button and an official mobile app. I’ve been subscribed to this service for over 3 years, and absolutely nothing. Honestly, it’s a bit baffling.

19 Likes

I use this userscript.

No idea whether it works on mobile though

2 Likes

Yeah, at some point the line between “eh, I could use the extra review” and “I KNOW THIS AND I HATE MY KEYBOARD AND WANKANINANI OESN"T HAVE ENIOJGHT SYNKONYMS” gets crossed and it becomes a barrier,… and more importantly, demotivating (which is a key issue in language acquisition).

On the iphone, I use the Tsurukame app and it’s mostly been bug free, even with the recent changes, but I don’t know what I’d do if I had an android.

13 Likes

Exactly this. Also, not having the option to undo makes reviews take so much longer, since you have to type slow and double check if there are any typos before hitting enter.

And nobody deserves having an enlightened item knocked down to guru because you wrote “abolishing” instead of “abolition”. That kind of BS just makes the user experience miserable.

It’s really incredible how much of the user experience is only made possible by user generated add-ons in WK.

Also, the lack of an official app is hard to understand. they would presumably reach a much larger audience if they had a spot on the app store, I’m not sure what’s holding them back

Sorry for the rant lol

15 Likes

It stopped working? In what sense? I use it every day and it works great.

Btw, I’m pretty sure they didn’t make a mobile app, because the web interface itself is mobile friendly (and it’s even being improved on that front). For those that want to have an app there are plenty of third party solutions, and making a first party one would end up with double the work for an end product that won’t rival the existing options for quite a bit.

I changed cell phones, and while setting up the app in the new phone it gets stuck in a loop in the insert V2 API screen. I tried uninstalling and reinstalling, but no luck. I’m on a Samsung Galaxy S23.
I couldn’t find any other third party app for Android on the Playstore, do you know if there is any other? It seems all the others are not compatible with the latest Android build

The problem with the mobile interface of the website is the scripts don’t work, such as WK double check

So I’m currently stuck with desktop only, or vanilla wanikani on the phone browser

I’d bring this up in the flaming durtles thread if you haven’t yet. Also, make sure you insert an api key that has the proper permissions.

If you are using a script-ready browser, they will work just fine. Stuff like Firefox or the Kiwi browser

5 Likes

I use ‘Kakumei for Wanikani’. It’s available on the Playstore. No undo button though. It used to have one, but that disappeared with the latest update. Oh how I miss it…

1 Like

Dude you just solved all my problems, no joke. I thought scripts didn’t work on firefox anymore, but I installed them and they work just fine

Thanks a ton! I feel pretty silly now tbh lol.

7 Likes

I noticed this too, though my Flaming Durtles is still working.

Nonetheless, Flaming Durtles also stopped getting updated for about a year now.

If it’s just Android version, I am certain that I can update from the source code. Not sure if I can fix other issues, though.

1 Like

Yeah, this is my guess too. I haven’t been around since the beginning, but most likely they once considered it but then realized others were willing to help on their own as passion projects… and some of those free options were really well-done.

Glad to hear you’ve found a way to fix the issues you’ve been having :slight_smile:

literally unusable

For the sake of anyone shopping around for a Japanese SRS service, happily at level 20 with no undo/reorder scripts used.

2 Likes

Double Check broke again today! Wanikani seriously needs a native undo button NOW. This is getting ridiculous and is completely killing my desire to use Wanikani at all.

10 Likes

This hasn’t been working well for me. I installed it, but the button often doesn’t show up. Now it doesn’t seem to function at all. Very frustrating.

Honestly, how the fuck is there not an option for a native undo button after all these years? Why are the devs so against the use of it? I literally only use it for actual typing mistakes when I knew the answer, but even if I wanted to abuse it, that should be my choice to do so as a user.

9 Likes

Agreed! I recently started using scripts but for whatever reason it stopped working yesterday.

I was using the Double Check script with TamperMonkey but whenever I hit enter/try to move on to the next word, WK doesn’t do anything.

I turned off the script and it started working again. Very frustrating! I wish they would just have it built in. The amount of times I got a word/kanji wrong for accidentally adding an extra letter or used katakana by accident is incredibly off-putting.

3 Likes

There was a podcast a few years back discussing the platform was intentionally built this way. They wanted a ‘Dark Souls’ / old school gaming approach that is a punishing platform where wrong answers send you back to the beginning as their way to reinforce learning. Ironically, no undo button for the update either, sending scripters back to the beginning as well…going back to their medieval roots it seems.

2 Likes

Don’t feel bad. My Enter key only works sometimes now–no scripts installed anymore. The Enter key is really…necessary.

1 Like

I agree with their philosophy in regards to actually getting the answer wrong, but the problem is when you know the answer, yet make an innocent mistake in typing it.

5 Likes

While I welcome the approvement of being a bit more lenient with mixing up meanings and readings etc. it’s still unacceptable not to have an undo button. I recently had a situation when I was supposed to type in a noun for a Kanjii, but I typed in a verb which was flagged as wrong. As far as i am educated Kanji are rough ideas, but definitely not specific types of words. Or sometimes I know the meaning, but can’t come up with the proper English term. You need an undo button for that. Period!

1 Like