WaniKani Explorer Update

Ahh, so thats why my progress bar for level 5 is -25 days and level 6 is 48 days! Stupid thing is making a mess out of my progress graph


I can’t download any report from the web, is it normal? I saw you mentioned an unicode bug, but i’ve tried different levels and they are all failing. 


Yeah, I just found this and I can’t download anything either but it’s still very nice to be able to see the info. If I really want the data I can view it 100 at a time and copy/paste it into a spreadsheet.

I really appreciate this, it’s a great project.

foolzesprite and eltercero –

Thanks for the message. Ugh – I haven’t worked on the project for a really long time. Glad to see some people are using it.

Sorry about the bug. I’ll take a look into the bug and try to fix it here shortly. Once I have that fixed, you should be able to download all your data. Stay posted!

OK – I fixed A bug (others are likely lurking). But, you should be able to download your data now. I’m not sure if this fixes all the download issues. Please pass along any other bugs you encounter.


Thank you so much for the fast fix. Like you said, there are issues with the unicode characters in Excel but (pinging @eltercero) I was able to open the .csv in Google Spreadsheets and quickly remove all of the extra columns to show just the kanji, meaning, on’yomi, and kun’yomi. Can do similar with the vocab, obviously.

Works like a charm, thanks again!

Yay, thanks! I’ll try it out later.

Thanks for the ping, @foozlesprite

@ZenBrayn, your app is great!^^

The site doesn’t seem to be working for me. I enter my API key, it says gathering user data and then says “disconnected from server” after 5-10 seconds?

Thanks to all above for the well wishes!

@Ashi2015 – very odd. I see you’re level 23 so you have a lot more data to pull than myself (at mere level 5). Not to place the blame, but there could have been a hiccup with my app accessing the WaniKani API and their servers. Could you try again and see if you still have issues?

If you are still having issues, I’d need to your API key so I could debug further. Do the new forums support DM’ing? Otherwise, you could post here if you’re comfortable with that (some people are, some people aren’t). Other-otherwise, pass along any additional info on the problem.


@ZenBrayn I’m having the exact same issue. I tried both on my work computer and my home pc. also. Tried disabling stylish and messing around with settings in my browser but no luck.

Hey ZenBrayn, yep still having the issue;

Here’s my API so you can debug :slight_smile:



@Ashi2015 Great – thanks for the info. I’ll debug this even to see what’s up. Thanks for testing!

@Ashi2015 @phurry OK – fixed a bug. Your data should hopefully load now.

Essentially the JSON response I was getting back for the vocabulary items wasn’t what I expected. There was probably some API change at some point and my code wasn’t up-to-date.

Anyway, let me know if you have any other problems.


Yep, works fine now. Thanks ZenBrayn!

@ZenBrayn Mine still seems to be broken. Cleared cache but the same error shows saying “disconnected from server. reload”. :sob:

Edit - This seems to be working now and all stats have pulled through!

I just updated the app to v2! Give it a whirl if you’d like :cowboy_hat_face: .



hi ZenBrayn, I’ve been getting the “Disconnected from the server. Reload.” error mentioned above all day today. not sure if that is anything you might be able to check. thanks for such a wonderful app!

Hi @Dwane! Thanks for using the app. I just checked out the logs and there might be something odd going on with an invalid character in one of your reading notes. Do you use reading notes? If so have you recently added one with a potentially unusual character in it? The error that I’m seeing has something to do with a reading note referencing “Jurassic Park”. If this is the case, could you give me more information so I can figure out how to squash this bug?

I’m not exactly sure if this error is coming from your data or not however. If the above doesn’t apply, let me know.

Thanks again!

I typed in: a BIG guy is wearing a huge TieDye (たい, だい) shirt. Think of Dennis from Jurassic Park.

it’s possible I reference that in another note somewhere. that may be the case since I deleted the comment above and I still get the error.