[Userscript] Stroke Order Diagram

I got this bug not too long ago but didn’t look into it. My hunch is that an SVG diagram is being drawn twice in the same DOM element.

1 Like

Probably not the best way to do it, but in favor of saving some time I decided to just always clear the element before drawing. I don’t see any difference on the kanji pages or in reviews, so I assume this fixes it, at least. Please tell me if you encounter this bug again

https://greasyfork.org/en/scripts/414633-wanikani-stroke-order

2 Likes

will do :slight_smile: thank you!

Is it just me that keeps having problems with this script? I can’t see the stroke order. Usually I just delete the script and reinstall it, and then its fine. But then I have to do that over and over again :slightly_frowning_face:
And this time I can’t install it again because when I click install (not just this script, but any script) it goes like this

and then doesn’t appear on the TamperMonkey dashboard. How can I fix this?

Thanks for the script though! I love it :smiling_face_with_three_hearts:

Well it shouldn’t be downloading the script at all. What browser are you on?

Chrome. It used to install normally but not anymore.

Are you sure you’re clicking the right link? And you still have tamper monkey installed? If so I don’t know how to help you

Yes, and I’m doing the same thing I’ve always done. It’s okay, thanks for trying anyway :slightly_smiling_face:

Okay, I think I accidentally fixed it :joy: I went to Extensions, Tampermonkey, then turned on “Allow access to file URLs”. Now it’s installing like usual.

This is odd. I have this option turned off on my Tampermonkey and it works fine. Something else must be going on.

Works great, thanks!

1 Like

Thank you, Kumirei! I love having the stroke order added to WankKani. As part of my study process, I write down every radical, kanji and vocabulary word that I get wrong in reviews. Having the stroke order pop up helps me write the kanji in correct order.

One thing I noticed is that Greasemonkey didn’t work for me. I thought I installed the script on Firefox, but nothing changed (I don’t have a lot of experience with adding extensions, so it could be me). However, when I used Tampermonkey, it worked!

Just want to say thank you.

1 Like

No problem! Note that I am just maintaining it though, I am not the original author

I know that Firefox has some issues with some of the script handles (in general). Not sure what the cause is and I never remember which extension it is, though. Glad you got it working!

3 Likes

Ah, thanks for the clarification. Well, thank you, @Kumirei, for maintaining this most useful userscript! And thanks to @looki for creating it!

2 Likes

Hi @Kumirei, thank you for maintaining it! I used for a bit the old version maybe one year and a half ago. I’m on Google Chrome with Tampermonkey and the script doesn’t work. I tried by only running it alone but nothing (the svg doesn’t show up), do you know why?

I’m a noob in programming so I can’t tell but I get two errors:

1 Like

Hmm, it’s working fine for me, but it looks like it’s failing to load the diagram for you. First make sure that you are on the latest version (1.1.6). Then maybe check if it’s being blocked by another extension (ad block, anti-virus, etc)

2 Likes

The script, Tampermonkey, Google Chrome are up to date and I disabled anti-virus, other scripts and extensions, nothing yet

1 Like

Could you take a screenshot of the console so I can see what the error says?

1 Like

1 Like

Thank you! I assume you can access the Jisho kanji page without issue?

1 Like