[Userscript]: Reorder Ultimate 2 [newest]

You can also leave the vocab field blank to keep all vocab lessons. :slight_smile:

2 Likes

So I’ve been getting a few problems recently.
First, it appears doubled on the screen.


I thought this would be fine as long as it was still working (for example, if i deleted the radicals, all four of the bars would disappear.)

But then, a radical still appeared in a kanji only study.

I then reinstalled the newest version, and the parts that were being doubled was fixed, but radicals showing up in a kanji only study is still happening.

Any ideas?

Right-click on radicals and kanji to remove them

1 Like

thanks, that seems to work

Lately, I’ve been doing increasing level, vocab, then kanji, then radicals, and had a radical show up in the middle of my vocab lessons.

Also, lately it’s been randomly getting stuck on one lesson. It might be the first one of the batch, or it might be a later one. But at some point, it’ll just keep repeating the same lesson, with no way to advance. I tried WK Lesson Filter, too, and it also got stuck, so I suspect something’s changed on the backend that’s broken both scripts.

2 Likes

Based on one or two other threads, it sounds like there may be some recent Wanikani changes causing the “getting stuck” issue. At least one person said they have the issue without using scripts.

I am also experiencing the “getting stuck” in lessons issue. I think for me it’s just this script as every time I turn it off everything works fine.

Also having problems in lessons with this script.

For some reason the Breeze Dark theme hides the minimize button.

minimizbotanegadokodesuka

I’m not sure why it disappeared, but I fixed it in the style.

1 Like

Thanks, I really appreciate this! :slight_smile:

1 Like

This script has started to break constantly for me… I checked both framework and reorder are on their latest versions. Also, I’m using Violentmonkey. Could I get some help please?
What do I mean by break? Well, sometimes it doesn’t show up at all, sometimes it shows up twice, sometimes the interface shows up, but it’s missing the levels.

How long has it been doing this?

Just based on the type of issues, my first suspicion is that you either have two copies of the script running somehow, or another script is causing havoc… though I don’t rule out other possibilities yet.

Just as a sanity check, can you start by turning off the copy of Reorder that you are aware is running, and see if the Reorder interface still shows up?

If I turn it off, the script disappears as expected. Also the script has stopped acting up currently. Maybe turning it on an off has fixed it somehow? I won’t count it as a win just yet, I’ll report back if it starts acting up again.

1 Like