[Userscript]: Double-Check (Version 2.x)


#61

Still seeing that undefined warning.


#62

@seanblue @Oshin,

:point_right: [ v2.1.3 ] - Fix no-cigar ‘undefined’ message, add item-info settings, rearrange settings

The Settings dialog is rearranged onto several tabs now:

image

image

image

image


#63

I’ve just tested it. Excellent! It worked now!

4h later. Edit: The SRS Level in Review only worked for the last item (Thing like “Apprentice” after I answered reading and meaning for an item). The other items’ message were still swallowed/gone like my first bug report (though I don’t have to press “F” when I’m wrong now). I’m back to WK Override & WK Lightning Mode now until it’s fixed.


#64

I’m definitely going to get this a go Because I use voice For the English definitions and sometimes Siri doesn’t understand me.


#65

Have you thought about adding a toggled option “Automatically open Item Info” to “Delay when multiple meanings”?

You know where the question is coming from)


#66

A shortcut for lightning mode would be nice :eyes: :smiling_face_with_three_hearts:


#67

Override stopped working for me so I finally switched to Double Check. I have one issue, though. With Double Check off and the old lightning mode on, I get no green bar when I answer something correctly, but with Double Check on, and only “allow retyping” checked, I do. It’s rather annoying.

Is this something you can fix?


#68

:point_right: [ v2.2.0 ]

  • Fix SRS up/down popup in lightning mode
  • Fix green bar blink in lightning mode
  • Fix button auto-layout (was incorrect when Reorder not installed)
  • New auto-info options.
  • New option for setting SRS up/down popup duration in lightning mode.

image

image

@Kumirei, @Oshin, @EyeShield77

@FlamySerpent ,
I’m not convinced of the value of a hotkey for lightning mode, though you’re welcome to persuade me.

Did you know about the quick-enable button? (You can enable it in the settings)
If so, do you really toggle it often enough that clicking the button is burdensome?


#69

Sometimes I would love to check all of the other meanings/reading to the word or kanji so I would have to toggle lighting off. I do that by clicking that button, but I have to take my mouse. That takes a lot of time and lightning mode is all about the speed, isn’t it? :wink:

Was that good enough?:DD

Edit: Also I’m sometimes afraid that I might get (in)transitivity wrong, so the quick check would be nice. And some other instances where I might forget how to write that word correctly in english


#70

:point_right: [ v2.2.1 ] - Add hotkey for Lightning Mode (Ctrl-L)


#71

Thank yoooou!! I really do appreciate it! :smiling_face_with_three_hearts:


#72

@rfindley Looks like the popovers generated by the script no longer show up on top of the buttons.

image


#73

Interesting… they did for me. Could you investigate the z-index?


#74

The z-index of the popover message is 1000. The buttons themselves don’t seem to specify a z-index, but the div containing the button set has a z-index of 11 (id=additional-content). When I turn my scripts off, the z-index for that element is 0 and it displays correctly. It looks like line 569 of double check adds css that changes the z-index to 11.

Of course, 1000 is obviously greater than 11, so I’m not sure why this is happening. Granted, my knowledge of how z-index works isn’t great…


I’m out of reviews for the night now, so I can’t help investigate anymore. If you look into it more, close but no cigar from double check or an on’yomi/kun’yomi warning should demonstrate the issue. The “multiple readings” warning doesn’t demonstrate it because that message is displayed lower.


#75

Ahh, that explains it. Thanks for the investigation!! I’ll work on this in the next few days.

If you’re ever interested, I have a script that blocks review submission. It’s super handy for testing review-screen scripts. Just refresh, and all of your reviews are back where they started.


#76

Thanks! :pray:


#77

This script doesn’t seem to work for me :confused:
I get the following error message:
“ERROR: Execution of script ‘Wanikani Double-Check’ failed! wkof is not defined”
I’m running firefox 65.0 on Linux

Edit: I clearly just forgot the dependency on Wanikani Open Framework


#78

Still getting this with 2.2.1.
I have enabled retyping, delay when wrong, lightning mode (and button), and open item info when wrong.


#79

Thank you! You’re a national hero!


#80

Hmm… I was unable to reproduce it originally, so the changes I made were speculative. I think I’m even skipping the part where it turns green, though WK’s code still undoubtedly changes it very briefly… though that should be true of the standalone Lightning, too.

Are you on Firefox? I know FF rendering is much slower (in my experience), so maybe that’s why I’m not seeing it in Chrome.