[Userscript]: Double-Check (Version 2.x)

Yeah, I probably should do that. I think, at the time, I was doing a speed-patch when WK changed how subject_ids worked.

2 Likes

Hi @rfindley

I observed an expected behavior with this script, that may need a fix.

In the case where the english meaning is a transcript of the japanese word (eg. ‘納豆’ ‘幕府’), it seems possible that the script will just shake and not error out when the japanese spelling is typed incorrectly.

In my particular case of today, I typed incorrectly ‘なっと’ for the reading, and it just shoke, and did not give an error. The correct spelling is ‘なっとう’.

1 Like

It’s because “natto” is also the accepted Meaning, and when you have “Allow typos” enabled, it warns when you’ve entered the Meaning instead of the Reading.

I’m not sure what settings you have, but I’m seeing the pop-up message “We’re looking for the reading, not the meaning”. Are you not seeing that?

2 Likes

Thanks, you mean that this symptom happens only because I typed ‘なっと’ which happens to be the correct spelling of the meaning answer, even if WK was asking for the reading. It makes sense.
My settings were as below:

2 Likes

Sorry if not entirely on topic but is there any place where wanikani typo detection is described?

I just can’t figure out why “police office” is not a typo for “police officer”, is it because it is a possible translation of another word from the vocabulary?

1 Like

They use the Levenshtein distance

But this is not the whole story. They also check the contents of an allow list of permissible answers and a block list of banned answers. If you want to consult the contents of the allow list and the block list it is available in Item Inspector. (Disclosure: I am the author of Item Inspector)

2 Likes

Thank you, will definitely check Item Inspector, I have some understanding of Levenshtein distance but allow and block list are news to me for sure!

Just a small thing, but since we don’t get a “Correct” notification in Lightning Mode, an optional satisfying ping sound would be nice! :smile:

Thanks for setting this up

Brilliant script. Is there any way to have “Show All Information” automatically expanded upon wrong answer? If not, would a hypothetical script that does that be able to coexist with Double-Check?

Is this what you’re looking for?
Settings -> Item Info -> Show Item Info -> After incorrect answer

(And, of course, the settings are accessible via the gear icon in the top left corner of the review screen)

I’m looking for something that will click the “Show All Information” button within the Item Info screen that that option already shows. I’m currently returning to WK, and therefore need to relearn a lot of the mnemonics, but the reading/meaning mnemonics are typically linked; this means that, when the randomness of the reviews presents the “second half” (the reading, I think) of the mnemonic first, I need to click through manually and read the “first half” to make any sense of it.

I suspect that this requires two clicks by default so that you don’t see the meaning when you get the reading wrong (and vice versa), but it’s my understanding that getting either the meaning or the reading wrong (or both) “punishes” you identically in terms of SRS level decrease. If this is the case, I’ll need to repeat the item anyway, so I don’t really mind spoiling the half I didn’t just get wrong. If I’m misinformed, then my request might not make sense.

1 Like

Makes sense. I wasn’t familiar with the Show All Information button. I haven’t done reviews in years.

Anyway, it sounds easy enough to add as a option. Maybe I’ll add it during my update spree in the coming weeks. (I finally have some time to update scripts and wkstats)

1 Like

Neat. Thanks for the consideration.

FWIW, I just discovered that spacebar does this by default.

Hi there.
I was previously using this userscript but after changing my browser to LibreWolf (Firefox fork) the script does not seem to load (the gear icon does not show for example). I’m using Tampermonkey with Wanikani Open Framework as the #1 Script. I also tried disabling all other scripts but still no luck. Also tried disabling all Extensions (like uMatrix) that could be interfering.
Hope someone can help me troubleshoot this issue. :slightly_smiling_face:

Any errors in the Javascript console? (press F12, then click the Console tab).

Given the browser name, I’m going to guess that indexeddb is not enabled by default.

Side note… I just started using Dissenter browser. I knew Chrome had been getting unreasonably slow lately for some reason, but I was shocked how fast Dissenter was comparatively, considering it is based on Brave, which is based on the Chrome codebase.

Librefox is just Firefox without telemetry and other bad stuff and the ghacks user.js. I can enter ‘indexedDB’ and get auto corrections so I’m assuming it has this functionality.

The only erros I get are

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/jquery-ui.min.js. (Reason: CORS request did not succeed).

and

Uncaught TypeError: notice.stack is undefined

coming from some honeybadger script.

re: indexeddb, I just meant that (like firefox with ‘privacy’ mode turned on) indexeddb may be disabled via settings.

Anyway, the jquery error is the issue. The browser, a browser plugin, or anti-spam app is most likely intercepting and changing the CORS header for security reasons, which causes normal things like jquery on googleapis to not load. I’m sure there’s a setting for that somewhere (e.g. ‘privacy mode’).

Ah okay. I got it to work after disabling my Pi-Hole for a bit. Thank you for the help^^