[Unsupported] Leech training script


#223

Yeah, but it also made sure that you didn’t review them too fast. Oh well, no point crying about it. It’s gone now.


#224

Too fast meaning too often? Or meaning too close to when they will be reviewed? If the former then I can’t help you. If the latter there is an additional filter for that as well.


#225

I’ve installed a new instance of hitechbunny’s server and updated it to correct errors (API url had changed), and also posted a new userscript: https://greasyfork.org/en/scripts/372086-shin-wanikani-leech-trainer

Basically, I use this a lot, and having it not working is Not Good for my studies. I just deployed their code quickly to a free heroku instance and changed the URL in the trainer script and my very basic, still-at-work testing indicates it’s doing okay.

Disclaimer: I know nothing at all about Go which the server is written in, so there might be proverbial colliding with spinning blades and I wouldn’t know at the moment.

Anyway, give it a shot and see what happens.


WaniKani Leech Trainer - Broken?
#226

I installed it and was unfortunately met with the same error page as with the original program. Is there something more that I’m supposed to do besides just download it and uninstall the old program?


#227

What error are you getting? It’s the same code as before on the server side, so it’ll still occasionally take a long time to complete. I’ve seen logs of some taking ~20s,


#228

I got this:

This site can’t be reached

wanikanitools-golang.curiousattemptbunny.com refused to connect.

Try:

ERR_CONNECTION_REFUSED


#229

That definitely shouldn’t happen with my version unless I missed a bit! Do you have both the old one and new one installed? If so, remove the old one.


#230

No I deleted the old version. I’m sure the error has more to do with my computer being uncooperative than an error in the program. I’ll try using it on a different computer and see what happens


#231

Hi, I am getting a bug recently when trying to use this script on Chrome.
The leech button appears correctly and when I click it I am shown the first asked item, but I cannot validate my answer using “Enter”.
I tried uninstalling and reinstalling the script but it does not change anything for me.
Did anyone met this issue before or has an idea to fix it ?


#232

The script hasn’t worked for many weeks. You can either install @rosshendry version of the script here or you can use Self Study + Additional Filters for a more stable but also more basic solution.


#233

God bless you @rosshendry, I didn’t realize just how much I relied on the awesomeness of the leech training script until it went away.

SO happy to have it back!


#234

I would dearly love to get a leech trainer script going again! Thanks @rosshendry!

However, haven’t been able to get new version working… Installed the Shin WaniKani Leech Trainer - same result as @Neykah describes above - the leech button appears and when I click it am shown the first item, but typing an answer and pressing the [Enter] key doesn’t seem to have an effect.

I tried uninstalling script, rebooting, reinstalling, same result. Chrome Version 69.0.3497.100

What am I doing wrong? Anyone have a suggestion or solution?


#235

That’s odd. Did you uninstall the original script before installing the new one?


#236

I’m not script savvy, not sure what’s important so, to tell the tale from the beginning:

Original Leech training script quit working so looked for alternative.
Installed Shin WaniKani Leech Trainer - type answer, enter key has no affect
Uninstalled both scripts, rebooted, installed Shin WaniKani Leech Trainer - no change.

Thanks!


#237

Are you using Chrome? If so, could you open the Developer Tools (it’s under More Tools in the three dots menu), then reload the page and see if there are any errors in the console tab.


#238

Chrome Version 69.0.3497.100

Here’s what the console tab looks like

18%201001%20Shin%20Leech%20Trainer

[edited to say] oops when I actually follow instructions and reload the WK dashboard page after opening Developer Tools the message goes away so…?


#239

That seems okay. Anything interesting if you open the leech trainer and try to provoke the error?


#240

After I type an answer to the first question and hit [enter] - nothing happens. If I click outside the Leech Trainer window it disappears and I’m back to WK dashboard. I’m guessing some setting or other on my end? What might some possibilities be? Pesky Bitdefender antivirus?


#241

The only thing I can suggest at the moment is disable any other WK related userscripts you have and see if the leech trainer works on its own. If it does, try different combinations see if there’s a clash.


#242

I still had to make the changes mentioned in [Unsupported] Leech training script to @rosshendry’s version or I experienced the exact same behaviors.