Trouble typing in Japanese on a Mac

Hello, I’ve been trying to figure out why trying to type in Japanese on my Mac is not working as expected. I’ve looked for help online, but everything is quite a bit old and doesn’t seem to work for my OS, etc. I do have Japanese input enabled and I can (with difficulty) type in Japanese, but all videos/guides instruct that hitting the “a” key would produce an “あ” character. Not so for me. Hitting the “a” key gets me a “ち”. I have no idea what to do to fix it or change it as the options are pretty limited on the input sources menu. I also tried installing Google Japanese Input, but couldn’t select it in the input sources menu and things got messed up (I probably messed them up) so I have uninstalled it for now and am back to the default Japanese option. Beyond the very basics I am not technically savvy so if anyone knows what I’m talking about and could help I would appreciate it greatly.

For reference my OS is Ventura 13 on a Mac mini M1. I’m using a Logitech K375s keyboard if that’s important.

I am sorry if this is the wrong place for this. I’ve been gone for a while. I’m also sorry if this seems redundant. The info on Tofugu for setting things up is for an older OS (as are pretty much all articles and videos I found as already stated) and didn’t matchup and I ran into some problems. Mac help was very sparse with help too.

I don’t have a Mac and I definitely don’t know how to fix it, but it definitely sounds like it’s on kana input rather than romaji input. The kana layout apparently looks like this:

I wanna say the IME should have kana input in the settings, but never having used it myself, I don’t know

4 Likes

Thanks for providing the image, that is exactly how the characters map and I cannot figure out how to change it for the life of me.

1 Like

Google says ctrl+space. Got no idea if that’s correct though (I’m on a PC - it’s in the context menu for us).

1 Like

I can move between English and Japanese input with keyboard shortcuts though there don’t seem to be options for altering the layout (and I’m trying not to poke around too much so I don’t break things). Thanks for the support! :blush:

1 Like

If you go to the system settings, section “Keyboard”, then under “Input sources” (I guess? my system is in German, sorry) when I click “Edit” to the right, I can add different keyboard layouts (with the plus sign in the lower left corner) and I have added a keyboard called “Japanese - Romaji”. When I select this keyboard, I can type e.g. “a” and it gets auto-converted to あ.

5 Likes

Looks like you installed the wrong keyboard.

You want this one:

Hit the plus button, type japanese, and select Japanese- Romaji.

This is the one you have installed:

8 Likes

haha! just took these same screenshots. this is the answer!

3 Likes

Awesome, thank you so much! Everything is working as expected now. Thanks everyone for the replies :blush:

6 Likes