[SOLVED]: Last reported vacation date is wrong


#1

A very minor issue. I’ve gone on vacation mode for at least two times this year (once in mid-february for a few days and then today-Saturday probably).

In the area where one activates vacation mode, there is a notice displaying the last time vacation mode was activated.

Both times I noticed that it said my last vacation was July 10, 2017.

Very minor issue, but there it is.


#2

I’ll take a look at this one — it’s minor, but those little details always bug me, too. :slight_smile:

To make sure the old troubleshooting information is covered, you’re seeing this in a browser with no extensions, yes? If not, is this in a mobile app? Or do you have any extensions or scripts that would mess with the display of https://www.wanikani.com/settings/account?


#3

Sorry–I’ve been offline for the last few days. I’m back.

I just reactivated my account from vacation mode. Logging in via my laptop on Firefox with a bunch of addons and Chrome with 0 addons, both browsers report a last activated vacation mode of February 16th–which was probably the last before last time I activated vacation mode.

My last activated vacation mode should be March 29th.


#4

Alrighty! We found the problem and pushed up a fix a few minutes ago. Your last vacation time should be on there and reported correctly. Let me know if it isn’t. :slight_smile:


#5

It looks great! I hope that wasn’t too hard to squash.

Thanks!


#6

Nah, easy peasy. There was a little logic error in there — we were looking at the wrong vacation. Tests written, logic fixed, and done. Thanks for pointing it out!