Mozilla Firefox Quantum and user scripts


#1

Hi all!
Apologies if this has been dealt with elsewhere - I ran a search to no avail…

I upgraded to the new Mozilla Firefox Quantum only to find the Wanikani scripts not working. I upgraded greasemonkey, but this doesn’t seem to have helped.
I then decided to head back to my old install of Firefox to discover the scripts not working there either - the new install must have changed some global settings that mean they’re not working.
Has anyone experienced the same? Any info on workarounds?

From what I can tell they’ve changed the way scripts work so all scripts might need a minor re-write in order to work from the sounds of things…

Help?


#2

Read this thread from here


#3

Thank you!! I knew my first thread would involve something that had already been discussed/sorted out… Gah.


#4

I switched from Greasemonkey to Tampermonkey for Firefox Quantum. Reinstalled all my scripts and everything is fine so far. I was bummed about Rikaikun not being compatible, so I’m using Yomichan for now.


#5

I’ve installed tampermonkey and everything seems to be back to normal with the exception of the ‘WaniKani Review Wrong Info Click’ script, which automatically brings up the correct info if you get something wrong. For some reason that’s still playing up, but I can live with that one…


#7

I tried using Greasemonkey on Mozilla Firefox, and it required me to upgrade to Quantum (when it was beta). Then when I installed the scripts, nothing happened. I just used Tampermonkey instead (which is what I use on my work computer with Chrome) and everything worked fine.