Wanikani Greasemonkey scripts all broken?

Ever since the Firefox 57 update (the WebeExtensions update, which broken the old Greasemonkey), I can’t get any of my greasemonkey scripts to work. Reviewing without them is just painful, it takes SO much longer, and has been super demotivating.

The ones I use:
https://greasyfork.org/en/scripts/11244-wanikani-real-numbers
https://greasyfork.org/en/scripts/12853-wanikani-lightning-mode
https://greasyfork.org/en/scripts/4749-wanikani-review-wrong-info-click
https://greasyfork.org/en/scripts/31455-wanikani-tab-key-to-info-click

I tried Chrome + Tampermonkey, but only lightning mode works (for some reason), the other three still do not.

Has anyone figured out how to get old greasemonkey scripts working again?

Hi, I think your question is answered in this thread: Scripts stopped working after firefox update

1 Like

There’s a new version of Double Check [here].

@rfindley That appears to be a completely different addon? Look at the descriptions.

@Lupa Hmm, I tried Tampermonkey, but only the ‘lightning mode’ addon worked. However I just discovered “violentmonkey” which appears to work for all the addons except for ‘review wrong answer click’. I’ll try contacting the author to see if he can fix it…

After the update I switched from greasemonkey to tampermonkey and downloaded the equivalent scripts. All of them work fine now, but I didn’t have the lightning mode script.
Hope it’ll work out for :slight_smile:

Oh! ‘Review Wrong Answer’ is working correctly, but it’s conflicting with Lightning Mode which now has that functionality built-in. So disabling the former fixes the issue. (I also found https://greasyfork.org/en/scripts/31455-wanikani-tab-key-to-info-click which is helpful)

Thanks everyone!

1 Like

The description is wrong on the new version because I used a different script’s code as a starting point and apparently forgot to change the description (doh!). But it actually does the same as Double Check, plus a few added features that are available in the settings.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.