Is WK down?

I don’t know if this is just me. I tried using WK on my iPad and laptop and found the same problem:

Just wondering if I was the only one with the problem :slightly_smiling_face:


Same here. Hopefully Covid19 hasn’t transmutated to infect web servers! :grimacing::wink:


Hold your breath! You might catch it from your phone!


Works for me both on my iPhone using cellular and desktop.

1 Like

It’s back up. Must have been shutdown to fix something.

1 Like

Still down for me.

1 Like

Huh. It’s probably best to just wait for WK to go back online.

Oop-- back up now. Thank the durtle gods or whatever!

1 Like

The site may be up, but I can’t login on my PC. Luckily my phone’s still logged in or else I couldn’t write this. No matter how many times I wipe the cache or try another browser, I keep getting the “You need to sign in or sign up before continuing” error. @viet @oldbonsai any ideas?


If you ever find yourself wondering whether a site is down I would suggest this tool (or any equivalent one).

1 Like

Same problem here. Can’t log in in either chrome or edge.


Same for me on Chrome–however works just fine. I did a few reviews, then checked flaming durtles on my phone and the review count lowered, so it seems to work just fine there.


This is also my problem right now. Had a scare that my account got banned or deleted or something! Glad it’s not just me. :confused:


Yep, same here, I can’t sign in Chrome or Firefox. I’m glad I thought to use an incognito tab instead of signing out. :fearful: Reviews are working fine for me though, everything is syncing. Seems like everything is fine besides sign-in. The preview site works as well.

1 Like

I couldn’t sign in on my laptop since I never save passwords, but what worked for me was resetting my password with the “forgot password” link. Once I set my new password it went straight to my dashboard. Not an ideal solution but I hope this is helpful for others who can’t sign in.


same here. not sure if it’s a school computer issue. seems to tap out when attempting proxy access. I hope there’s nothing Google that is being blocked
edit: used the preview site no problemw

1 Like

Still can’t sign in.

Did you try the preview site?

Yep, just did. I got in. but still curious if the regular entrance is okay.

I too, am having issues logging into my account. I found that I can only log in by resetting my password.