Can't type in English for definition

For context, I’ve been running double check and wkof without any issue like this.

had the same issue last night

1 Like

I havent been able to repro without scripts yet. Though it’s also worth noting that even with scripts it isn’t happening all the time. I had the issue yesterday morning with scripts enabled, then that evening had no issues without disabling anything.

1 Like

Ah ok, good to know. I’ll see what the others who have emailed about this say since if it’s not happening without scripts, then it may not be something that we can fix.

Hard to replicate the issue unfortunately. Happened couple of times in a row when starting my reviews, just reloaded the page and then had no issue for 100 reviews.
Tried on my personal PC now (just a couple of reviews) on Opera and no issue.
Don’t have JP keyboard nor scripts.

So, does anybody know, is this issue happening more often recently? And if so, how long ago did it start increasing in frequency? Maybe there’s a clue that can help narrow down the cause.

1 Like

I experienced this issue for the first time yesterday. I have a million add-ons so I won’t name them all, but I saw a few people mention Reorder Omega and Double Check in this thread which I am also using. I’m using Firefox. I just went back to the WK home page to restart my session, which fixed it.

I have had a version of this where occasionally a radical review will have me stuck in kana input mode, making it impossible to type the correct keyword. I am running Firefox with a lot of scripts, and chalked it up to some kind of bug or incompatibility between them. I have had this happen from separate computers, though with a similar setup.

When it happens I Later Crabigator the review away. It’s likely to happen again on the same radical when I see it again, and unlikely to happen on other radicals (I have never had this problem with a kanji or vocab). But by the third or fourth time the radical comes up for review, it lets me type in English, and all is well.

May be related, may not be. Feel free to disregard if it’s not the same problem and no one else is seeing my variant of the issue, I have a workaround I can use.

Edit to add - Not a case of just the OS being in Japanese input mode, one of the computers I had this happen to me on doesn’t even have Japanese IME installed.

I’ve also had this happen just once on desktop Chrome, I think Mac but it might have been on my PC. I don’t have any IMEs installed or any scripts/extensions.

1 Like

I just experienced this bug for the first time, using desktop Chrome. It happened with the first vocabulary item in the quiz after a lesson.

I couldn’t find a way to work around it. I tried copying and pasting the English text from another window, but the English text got converted to hiragana as soon as it was pasted into the answer field.

I had to give up on the quiz, but I came back to the quiz a minute later, quizzed the same item, and this time it was fine, with everything working as normal.

The next time anyone has this issue, could you gather a small piece of info and post it here?

Open the Javascript console (press F12 and click on the Console tab).
Type the following command and press Enter:


It should respond with either “reading” or “meaning”. It should say “meaning”, but either way is useful information for troubleshooting.

And if you want to fix it (just as a workaround until WK gets it fixed), you can paste this command into the Javascript console (and press Enter):


tried it out and got this:

Hmm, very interesting! Just to confirm, though… you didn’t refresh before typing that command, right? It was still converting english to kana?

Because if that’s correct, it seems what is likely failing is wanakana (not wanikani) not properly unbinding from the input box when it changes from reading to meaning… because it’s actually still converting text, but it doesn’t think it is attached to the input.

1 Like

Didn’t refresh, and after I let it check my answer as wrong the next prompt was also a meaning one and had the same issue. I ended up closing the tab but if it happens again I can test more stuff out

I have had the same problem. Refreshing doesn’t help. Has this problem been solved (somehow)? For one of those concerned?

Here’s an example of the problem in action:

This is not me accidentally typing Japanese characters in, my IME is on Alphanumeric. The text is getting converted on a card that it shouldn’t.

Going to the JavaScript console and typing $.jStorage.get(“questionType”) gives “reading”.

I’m having this issue too, for about 2 weeks now.
Before I’d be able to refresh and it would be fine. But now it won’t work. I even deleted my cookies and the problem persists…

Hey Everyone! We are planning on pushing out a fix for the input issue today (Monday). Would you mind letting us know if the issue persists over the next few days? We would really appreciate it!!!

You can post here and tag the mods or reach out to us via! :+1:

-Nick at WK


Hi Everyone,

I have been looking into this issue and I am struggling to reproduce the error, which makes it very difficult to understand what might be the cause of the issue. I released an update that should prevent the input being bound more than once but there have still been occurrences after that change. If you encounter this issue could you please do the following to help track down the cause:

  • inspect the answer input element and take a screenshot of the web inspector ensuring that the following is visible:
    • The web insector is on the elements tab and showing the input element - Illustrated by the first red arrow in the attached screenshot
    • If you have the console open you could use document.getElementById('user-response') to display the same result. Illustrated by the second red arrow in the attached screenshot
    • could you open the event listeners tab and expand the input event as shown by the 2 blue arrows in the attached screenshot. Could you please ensure all event listeners are shown (only the input needs to be expanded).

Hopefully this will help me track down what is going on.
Thank you so much for any help you can provide.


Here’s a screenshot, from Brave Browser on Arch Linux. I do have to apologize that my WaniKani is riddled with userscripts and they were all activated at this time, so hopefully the userscripts aren’t causing any issues. I did notice in my screenshot that a userscript was in the input event listeners, but clicking the remove button on that event listener did not resolve the problem. However, removing the first of the other two listeners did resolve the problem. On refreshing several times, I found that that listener appeared anywhere from 0-2 times, and the problem would appear anytime that listener was there twice. Every time there was two, deleting the first one solved the problem, but deleting the second one did not solve the problem.

This is maybe unrelated, but there was also a “Wanakana” listener in there only sometimes as well.

EDIT: Completely disabling the “Katakana for Onyomi” userscript changed the behavior more than I thought it would. After disabling it, the listener causing the problem wouldn’t show up as much, and whenever it did, it was only once and the problem was present. However the rate at which the problem showed up seemed to be about the same.

1 Like