WaniKani Scripts Not Loading After 2 Years

Hi, I’m coming back to WaniKani after being away for 2 years and I’m trying to reinstall tampermonkey and some of the scripts I used to use. But I can’t seem to get the scripts running, no matter what I do. I have them installed, with open framework set to the top priority, but they even though they appear to be active whenever I’m on the home page, nothing happens on the menu. I ran through 10 or so reviews and lessons, tried reinstalling everything, still nothing.

I am getting an error in the chrome extension menu, that says “Fetch API cannot load,” “scheme “chrome” is not supported”, and “Uncaught Error: Extension context invalidated.” but I’m not sure what would be causing that error. Any help would be appreciated, thanks!

Have you tried enabling just one script at a time? Start with one, if that works, add another and check again?

Which specific scripts are have you installed?

Yes, I’ve tried that, none of the scripts appear to work. Right now I have ultimate timeline, heatmap, and double check.

Heatmap, at least for me, broke when they changed something in the API and I don’t think there’s anything @Kumirei can do about it, it’s on the wanikani end. My ultimate timeline still works, don’t use doublecheck so can’t say.

1 Like

Some specific functionality (track across multiple machines/browsers) in the Heatmap script no longer works post API changes, but the script itself still runs and functions.

Huh, it was all blank for me, and I understood there was no way to get the data back. (In the past; future reviews might get recorded). I didn’t look that hard.

From what I understood, yes it can be blank under some scenarios. The core issue is that the script no longer retrieves historical review data from WK and data is now stored locally. That means that review data will only be stored for activity in that browser. If you use more than more one browser, you will see only history relevant to that browser. If you reinstall or clear browser local data, the history will be gone. Since data is not retrieved from WK, all historical data you had prior to the API change would also be gone as well.


When you say nothing happens on the menu do you mean that the script settings menu option does not show up in the dropdown when you click on your profile picture? Does the tampermonkey extension icon show a number for the scripts that should be running on the page? If there’s no number, rather than a problem with the scripts it seems there’s a problem with your tampermonkey install. I’m not familiar with chrome though, so I won’t be able to help with troubleshooting that.

Based on the errors you describe, it looks like something stayed in the browser even after uninstalling it and the old stuff is no longer valid. Try downloading fresh portable version of browser and install scripts there to see if that works. If it works there, try clearing cache and letting your main browser completely forget about WK before putting everything back.

I’d be careful about clearing your cache if you have heatmap, because if you lose your locally hosted heatmap data, it is gone forever (unless they bring the old API functionality back). I’d make backups of the heatmap data before doing anything that might wipe it, just in case.

Looks like this was the issue, cleared the cache and all the scripts started working again. Thanks for the help! (Still kept some of my old heatmap data too somehow!)

1 Like

If it’s the lessons data, that part is still retrievable through the API. It’s only the reviews that have to be stored locally (and are therefore lost forever if not backed up).

It’s probably good to mention here that the review cache heatmap creates is not stored in browser cache (or cookies), it’s stored in site data (which is more persistent storage and includes localstorage, sessionstorage, and the one actually used for this, indexeddb). So clearing your “cache” likely won’t delete it, but clearing “data” will. I don’t know how chrome manages this difference though as I haven’t used that browser in 5 years. With Firefox you can explicitly set what kinds of data gets cleared from a site and what gets kept.

Other reasons your review cache could be deleted are: the indexeddb for wanikani got corrupted somehow; Open Framework did file cleanup as it removes files that haven’t been updated for 14 days (or at least it’s supposed to looking at its code); something happens to the actual files stored on your drive.

1 Like