[Userscript] Wanikani Procrastination Annihilation

The Customizer used to do this! Was very annoying…
I wouldn’t be adding it anyway, but I hope it wouldn’t redirect you mid post! Could be infuriating!

I’m a proud member of the Secret Procrastinators Club… oh whoops! You read nothing!!                                                                                               [¬_¬]



What are the bars above your apprentice-guru-master-burned numbers from?

Despite being a master of procrastination I very rarely have over 120 reviews at a time. When I do, I just cry my way through them.

EskimoJo said... The Customizer used to do this! Was very annoying...
I wouldn't be adding it anyway, but I hope it wouldn't redirect you mid post! Could be infuriating!

I'm a proud member of the Secret Procrastinators Club... oh whoops! You read nothing!!                                                                                               [¬_¬]

 Lol, coming back to check on the topic and i had to do a few reviews first -_-
I'll probably build in some kind of offset in the next version.

Never used that customizer before. I looked it up and it was only released for Chrome (not available anymore) and Safari (don't use that) a very long time ago.

And no, it only redirects upon page load. I don't have the JS skills to do active polling and it would be both annoying and bad for performance (i think).
kaiken said... What are the bars above your apprentice-guru-master-burned numbers from?
 That's @rfindley's Ultimate Timeline. You can download it here: /t/Userscript-WaniKani-Ultimate-Timeline/10516/1

Mempo said...
kaiken said... What are the bars above your apprentice-guru-master-burned numbers from?
 That's @rfindley's Ultimate Timeline. You can download it here: /t/Userscript-WaniKani-Ultimate-Timeline/10516/1

 Thanks!

I know what I’m installing once I get on my computer 
HINT: This.

Aztrex said... Despite being a master of procrastination I very rarely have over 120 reviews at a time. When I do, I just cry my way through them.
 At Level 33,  surely you must wake up to over 100 reviews all the time.

I don’t procrastinate on my reviews, but I do check the forums more often than I’d like. Could there be an option to make the forums hidden all the time?

Said I was going to install this when I got on the computer. Then I got distracted by forums for an hours once I got on.
I’ll install this now then finish up my reviews. Sigh~

Bwahaha - I don’t know what I was expecting. 
Too bad my procrastination comes from browsing other sites. 

Using Tampermonkey on Chrome, it’s not working. It gives me the popup that takes me to the settings page, then it doesn’t do anything once it gets there. If I cancel it, it makes another popup every time I move to a page on WK saying “User not found”. I think I made it work by just manually setting apiKey in the script itself, but that seems inelegant.

TheySayMoop said... Said I was going to install this when I got on the computer. Then I got distracted by forums for an hours once I got on.
I'll install this now then finish up my reviews. Sigh~
 LOL. Another good example would be procrastinating by reading anti-procrastination articles. I do that more often than I'd like to admit.
Reckard said... I don't procrastinate on my reviews, but I do check the forums more often than I'd like. Could there be an option to make the forums hidden all the time?
Sure. Seems a bit harsh though. And if it's just a checkbox, what's there to stop you from unchecking it when you feel bored? I'll think about a better solution for this.

mahum said... Bwahaha - I don't know what I was expecting. 
Too bad my procrastination comes from browsing other sites. 
Sorry, can't help you there. Already plenty of plug-ins for that.

NordicRest said... Using Tampermonkey on Chrome, it's not working. It gives me the popup that takes me to the settings page, then it doesn't do anything once it gets there. If I cancel it, it makes another popup every time I move to a page on WK saying "User not found". I think I made it work by just manually setting apiKey in the script itself, but that seems inelegant.
 Do you have slow internet? Technically nothing could go wrong, but while testing, sometimes i would hiccup because the script didn't load properly.

EDIT: now i think about it, it's quite possible Tampermonkey and Greasemonkey scripts are not totally interchangeable. I'll test it on Chrome today.
Mempo said...
NordicRest said... Using Tampermonkey on Chrome, it's not working. It gives me the popup that takes me to the settings page, then it doesn't do anything once it gets there. If I cancel it, it makes another popup every time I move to a page on WK saying "User not found". I think I made it work by just manually setting apiKey in the script itself, but that seems inelegant.
 Do you have slow internet? Technically nothing could go wrong, but while testing, sometimes i would hiccup because the script didn't load properly.

EDIT: now i think about it, it's quite possible Tampermonkey and Greasemonkey scripts are not totally interchangeable. I'll test it on Chrome today.
 I have 8/1 Mbps. Not amazing, not horrible. Computer is mid-range parts from 2013, so not super slow. Script does not work, even with the API key being entered manually. I think the problem's with Tampermonkey/the script.
NordicRest said...
Mempo said...
NordicRest said... Using Tampermonkey on Chrome, it's not working. It gives me the popup that takes me to the settings page, then it doesn't do anything once it gets there. If I cancel it, it makes another popup every time I move to a page on WK saying "User not found". I think I made it work by just manually setting apiKey in the script itself, but that seems inelegant.
 Do you have slow internet? Technically nothing could go wrong, but while testing, sometimes i would hiccup because the script didn't load properly.

EDIT: now i think about it, it's quite possible Tampermonkey and Greasemonkey scripts are not totally interchangeable. I'll test it on Chrome today.
 I have 8/1 Mbps. Not amazing, not horrible. Computer is mid-range parts from 2013, so not super slow. Script does not work, even with the API key being entered manually. I think the problem's with Tampermonkey/the script.
I tested the script a few hours ago on Chromium (i use Ubuntu) and everything went smoothly (even with horribly slow internet). So i can't test it on Chrome.
Since i can't recreate the problem, it's going to be hard to debug. Technically, the only problem it could be is that Tampermonkey isn't handling the Greasemonkey-specific functions very well. They emulate their functionality, but it's not 100% the same. I will soon replace these functions to enable better cross-browser compatibility.

The only thing i can recommend now is try to install it from scratch. And if you can, look at the dev console(right click anywhere>inspect element>navigate to console tab) to see if there is any output. The very first line of the script prints "started Wanikani Procrastination Annihilation BETA", so if that isn't showing up, the script has an error/got corrupted.

Mempo said...I tested the script a few hours ago on Chromium (i use Ubuntu) and everything went smoothly (even with horribly slow internet). So i can't test it on Chrome.
Since i can't recreate the problem, it's going to be hard to debug. Technically, the only problem it could be is that Tampermonkey isn't handling the Greasemonkey-specific functions very well. They emulate their functionality, but it's not 100% the same. I will soon replace these functions to enable better cross-browser compatibility.

The only thing i can recommend now is try to install it from scratch. And if you can, look at the dev console(right click anywhere>inspect element>navigate to console tab) to see if there is any output. The very first line of the script prints "started Wanikani Procrastination Annihilation BETA", so if that isn't showing up, the script has an error/got corrupted.

Updated it, and a fresh copy doesn't get logged in the console at all (reinstalled it to be sure).

EDIT: Now it's "working" like it did before. Takes me to the account page, and then does nothing. Console doesn't show it loading or throwing any errors.

I dunno if it’ll help, but I installed it on chrome and it works fine for me

Emerald said...
Aztrex said... Despite being a master of procrastination I very rarely have over 120 reviews at a time. When I do, I just cry my way through them.
 At Level 33,  surely you must wake up to over 100 reviews all the time.
 I do quite often, but it rarely goes beyond 120. I always do my reviews before I go to sleep so that I can get reviews done in the morning and not be left with a backlog at school or in the afternoon. I normally have 200-250 reviews per day but spread out.
TheySayMoop said... I dunno if it'll help, but I installed it on chrome and it works fine for me
 Nooooo! That just makes it even more difficult. So it only works for some Chrome users. Great. Now i gotta look at possible interference from other scripts etc. Aiaiai.