[Userscript] Self-Study Quiz


#445

… Wh-why?

… I have Firefox… it uses the Grease…

But yeah, I have 5-6 installed now, and I’m seeing none of them. I was beginning to wonder if Timeline and Dashboard weren’t showing up because I’m on Vacation mode, but then at the very least Self-Study and the “Hide” radicals etc. one should work on level pages… ~_~

I’m so sad…

T_T


#446

Tamper Monkey is available for Firefox too. :wink:


#447

It wasn’t before…


#448

Hi Folks: In the self-study quiz, when I select SRS Level Aprentice 4 as the only filter, I get +200 items to review but my total number of Aprentice items is 147. Can anyone try to replicate this problem? Is there any obvious error I might be doing?


#449

You probably have it set to study in more than one way (e.g. EN->JP and JP->EN), so that number could be double (or even triple) what you actually have.


#450

Thank you! So the 210 are probably 105!


#451

@seanblue is correct. It counts the number of questions, not items. Reading and meaning are each 1 question (also audio, en->jp, etc…)


#452

If there are radicals in there, they only have meaning. So 210 could be more than 105. For example 50 vocab, 50 kanji, and 10 radicals = 2x50+2x50+1x10


#453

This thing is great. I guess the only thing I wonder is how it affects the SRS.

But one thing that I think is awesome is that you can set it to audio. If you have not done this before, try it out. I’m at a pretty low level still, but to listen to the words and try to figure it out, was much more difficult and took much more thinking. I mean, the reading part is usually easy because they are saying it and you just have to type the hirigana (although sometimes it is hard for me to understand the voice) but then you take what you heard and figure out what they are talking about. I mean, it might just say し and then you’re stuck going “city?” “doing?” “child?” and I’m sure I’m just getting started with these homophones. Honestly that is my biggest worry with speaking, so many homophones, how do people understand each other? I know the context is important, but even then, it seems ridiculous. How will I know what the heck the person is referring to?

Lol, anyways, thanks for this script.


#454

Homophones aren’t that big of an issue, but it’s true that last week I was speaking to my in-laws and got stuck a couple of times thinking of the wrong word… Specially when someone uses a new word you never heard, you will instantly map it to something you do know and get confused.


#455

Noob question, and maybe better placed somewhere else. This is the first userscript I’ve installed, and it’s not showing up anywhere or making any changes. I’m using Firefox/Tampermonkey, and I’ve got Open Framework installed and placed at the top of the list. I don’t have a “scripts” submenu like in the screenshot at the top of the thread (although the initial post is about 2 1/2 years old, so WK may have changed a bit since then.) How do I get to the quiz?


#456

The screenshot should be up to date. rfindley edited the initial post with the latest screenshot. It has nothing to do with WaniKani changing anything as Open Framework / Self Study adds that menu section.

Can you post an image of your tampermonkey script page? Have you installed the Self Study script in addition to Open Framework?


#457

I have both installed. Here’s the Tampermonkey page:


#458

Looks right to me. Can you check the dev console on the WaniKani homepage by hitting F12? If there are any errors paste them here.


#459

There’s this:


#460

The indexdb line is probably the problem. That’s what keeps a local copy of all the API data for the script to use. I’m not sure how to fix it, but @rfindley probably knows.


#461

I’m guessing this is Firefox?

Depending on your privacy settings, indexedDB may be disabled. Try temporarily disabling the always-private mode if you have that turned on.

If that’s not the problem… Firefox had a bug a few versions ago that corrupted the indexedDB, and upgrading doesn’t fix it (last I checked). But uninstalling and reinstalling with the latest Firefox fixes it.


#462

I am following this conversation.
I have had trouble with the self-study script for a few months, and have been trying to track down the root of the problem.
I run Firefox with tons of script blockers and security measures, so I figured that it was one of them.
At this point, I have disabled any setting that I can think of.
I still get this:
image
I am going to try updating Firefox. This problem is on both of my computers.
I haven’t wanted to ask about it because I was sure that it is something stupid that I am doing. :slight_smile:

Thank you for your work on this script!


#463

I installed the latest Firefox (63.0.3) and am still having no luck. I’m not using any kind of private mode, but I am running some adblocking. Disabling the adblockers doesn’t help.


#464

@RoseWagsBlue @charlescasimiro,

Just to confirm, make sure this isn’t checked in your settings.

You may also want to check whether cookies are disabled, because in the past Firefox linked indexedDB with the cookies setting. (I don’t know if that’s still true).

Anyway, I just updated my Firefox to the latest version (I only use Firefox for testing scripts). I was able to get Self-Study to work fine. But I don’t have any plugins except TamperMonkey, and my privacy settings aren’t locked down.