[Userscript]: Double-Check (Version 2.x)

This would certainly be the case, but theres other side to the story too. Ive seen many negative reviews of Wanikani that mentioned as at least one of the problem strict answers that reject close enough meanings or synonyms.

And i cant blame them either, how would they find they can use scripts? You would have to browse forums of someone reaching level 60 and writing about scripts (like jprspereira). Even the built in synonym system isnt as useful, people cant add anything during lessons and during reviews it wont let you continue with correct answer, so its just for the future.
Not to mention that its not super clear that synonyms are actually something you can use in reviews to get correct answer, i thought its just memo space similar to the meaning note, but it wouldnt get accepted.
Lastly some people arent tech savy and dont want to install any scripts because they dont know what that entails, which i think is great - i dont think anyone should install anything 3rd party which they have no clue about how it works.

All in all i wouldnt use WK if this script wasnt here / i couldnt use it (and i really mean it would be literally unusable for me) and just the fact that this service requires sizable monthly payments instead of one off payment (and no, $300 isnt reasonable one off payment) without actually providing any continuous service and improvements (and no, adding 20 items every year also isnt continuous service) is hard to recommend to people, despite it being the best way how to learn kanji in my opinion.


Thank you! You speak from the bottom of my heart in every respect :blush:


We did already have someone (multiple people?) blame WaniKani for their harmful sleep schedules as they couldn’t make themselves prioritize their sleep over doing as much of WK as they could. I think in these kinds of cases, it will be easy for people to decide if they agree or disagree with such reviews.

Yes, 100% agreed with all these reasons.

This I especially agree with. As other comprehensive apps get better and better, I find myself less likely to recommend WaniKani. I wouldn’t consider WK and Renshuu to be competitors, but if I have a friend asking what’s best to use to learn how to read, I’m going to recommend Renshuu. Unlike WK, it has grammar, more comprehensive vocab, and kanji. It’s a one stop shop. WK’s method for kanji specifically is better, but at the price it’s at, if people are paying for other resources, how will it be worth it to them? I think the team recognized this problem when they started working on EtoEto. But it’s been years at this point with no news. It feels like WK is determined to stay in a niche with a set way of thinking. I feel like they’ve done well enough in the past because Japanese learning is so fragmented. As that fragmentation gives way to innovative educators though, there won’t be a point to WK having a niche.


Double check started being weird for me on my laptop. Like lightning mode was on and it wouldn’t show me the answer was or delay if I typed it incorrectly. I uninstalled and reinstalled it and now it’s acting completely different. After I press enter it starts loading and then pulls up the same screen again and does nothing. Is 2.3.3 the newest version? It’s just so weird that it started acting different out of nowhere. On my home computer it works fine.

Is there another script that lets you at least undo in case I can’t get this working right?

@michellespeering , v2.3.3 is the newest.
Try going tk the WaniKani settings and see if you have Script Compatibility Mode turned on (it should be off). Also, try turning off any other scripts (except Open Framework) to see if there is anything else interfering.


I may be mistaken, but I don’t even think compatibility mode is an available option anymore. I don’t see it under app settings. I’ll compare my home and laptop settings later. Thanks for the response. :slight_smile:


Ahh, you’re right. It was still there last I looked, but it’s not now.

Try also making sure Open Framework is up to date. There were some changes a while back in response to some WK changes, and maybe Double-Check is being affected by those.

And again, make sure other scripts aren’t interfering.


As it turns out I’m just a goof and I had both regular tampermonkey and the beta installed at the same time. No wonder wanikani was confused. I thought the beta had overridden the regular tampermonkey app at the time. I’m not sure how it’s still working correctly on my desktop at home.


English meaning questions may have some value, but I also re-check with Yomichan and outside dictionaries.

I am here to thanks for having - and + buttons, although there are not on by default.

I wonder if this can be implemented for Shake When Not Exact? It’s sometimes difficult to progress at all (other than retyping with nn).

When I install the user script I get the warning that a script might not be working properly when I’m doing my reviews. I also noticed that I can’t add synonyms during a lesson if the script is activated. I can adda synonyms, hit enter and can see that it is there but when the Radical/Kanji/word appears again the synonym doesn’t exist anymore.
Older synonyms are still there I just can’t save new ones.

1 Like

I think this script broke, when I have it on it immediately moves on to the next question if I got the answer correct

I had lightning mode on and it disabled lightning mode when I disabled this specific script
so I guess it was just me bumping the option on

I’m not sure if this is an addon-specific issue or simply one related to the WK Open Framework.
I installed the addon, it’s even displayed as enabled in the tampermonkey box. It doesn’t seem to actually do anything though, the boxes for marking my answer as correct etc. aren’t there.

“Heatmap” isn’t working either, but “Pitch Info” is.
Within the tampermonkey dashboard, there is a “1” in the “#” column next to the WKOF, which is I think how it’s supposed to be…

Turning off uBlock Origin (the firefox security addon) doesn’t seem to help, if I see correctly…
I am running WK in a private window, could that be an issue?


Are you using Strict Privacy mode in Firefox? Last I checked, Firefox disables indexeddb in Strict Privacy, and indexeddb is required by Open Framework to store WK data. It’s unfortunate that Firefox’s settings don’t allow you to change that on a per-site basis (last I checked).


I was about to write that I just noticed that the WKOF stuff generally doesn’t seem to work in Privacy Mode.

So your answer makes sense. Thanks for the quick reply.


Recently, when using this script, it is messing with the reviews. It doesn’t matter what I type, it doesn’t trigger wrong. And also the wrong/right kanji counter isn’t updated, it’s only the item to review that changes. Does anyone else have this issue?

Sorry for the slow response.
The script seems to be working fine for me. What browser and script host are you using? What other scripts do you have running on the reviews page?

I’m using Tampermonkey and Google Chrome, I tried to de-activate all scripts and then activate them one by one. It happens, for instance, if I have only Double-Check and Open Framework activated, as in the screenshot.

Looks like you need to update to the latest versions of Open Framework and Double-Check.

1 Like

Now it worked, thank you very much.

1 Like