Heatmap Userscript gone with the new layout update?

Hey, has anyone else’s heatmap disappeared with the new layout update? Does anyone know how to get it working again?

Thanks!

1 Like

Mine was ok until I saw your post, checked and it was gone! Noooooooooo.

I was JUST about to take some sexy 100 day pics too, I am so upset :pensive:

(Edit: It’s back again… taking some 95 day pics just in case)

It’s back? I tried reloading the page but mine is still gone :sob:

I guess everything is gonna be oscillating this week :sweat_smile:

Oh well. What can we do :sweat_smile:

Mine’s working just fine, displaying right under the apprentice/guru/etc. counters.

1 Like

Mine is also loading fine. Maybe it has to do with your browser? I’m on Firefox. I don’t know if after an update like this if some scripts need to be updated as well?

Do you have the latest version of the script installed? If so, try a Ctrl+F5?

I don’t think it’s my browser. I usually use chrome, but I pulled wanikani up on firefox and still no heatmap! And I have the latest version of the script.

I do have the latest version and I’ve reloaded the page several times. I even tried reloading the heatmap from the settings panel. The settings panel does pop up, but the heatmap doesn’t load.

I figured it out guys! I removed it and re-downloaded the script! My heatmap is back now! Thank you so much for your help!

2 Likes

Hi there, can anyone please help me how to relaunch the heatmap? I am using Chrome and the script is not working for around a week already. Initially I decided to wait for the main WK updates to check it afterwards - and still a no.
I have deleted and reinstalled the script right now, but still no results…
When opening the Dashboard, I see a small window with “WaniKani reviews - collecting data” that hangs on for around 5-10 sec, and then nothing happens.

I miss my heatmap a lot, it is a good inspiration for me each day…

Others say the removing it and installing it again works, so start with trying that. You should be able to see a trash bin on the far right to remove it

Then install it from here again
https://greasyfork.org/en/scripts/377336-wanikani-heatmap

2 Likes

Hi Kawazoe,

Before deleting it, check the heatmap box in tampermonkey and select the “force update” option. That has helped when it has disappeared in the past.

2 Likes

@Kumirei, @feistypotato - thanks a lot for the recommendations. Got to browser view only now and tried all you mentioned. Alas, it did not help. I see the same small window of loading data under the scripts, as below - and no heatmap (it is an old snap, but it looks the same now)

I have cleared cash, deactivated the vpn and the antivirus browser extension just in case, forced update for the script and then reinstalled it - no effect, ehhhh… :sob: :sob: :sob:

The only thing that is different about the Heatmap script is the site it leads to. Other WK scripts installed lead to “wanikani. com” and only Heatmap points to “preview.wanikani. com”. Is it how it should be?

Thank you a lot for your help!

Does the loading never progress? The Heatmap script is waiting for that data before it displays. If it never fully loads you may want to have a look in the console (F12 → console) and see if there are any errors in there.

I was always waiting for it to progress until the window disappeared at least. Opened the console as you advised and apparently there is some issue (sorry, have no idea what this means though :pensive:):

image

@Kawazoe What do you see if you click the link in the error?

@rfindley do you know under which circumstances the reviews endpoint would not finish loading? Not sure if that’s related to the error they’re getting, since I don’t access an assignments property for the reviews, but it might be.

@Kumirei, the link points to this:

h- have you done the lesson for the “ground” radical?

As far as I am aware data[0] should always point to the ground radical in this case.

What do you get if you put this in the console?

wkof.ItemData.get_items({wk_items: {options: {assignments: true}, filters: {item_type: "rad, kan", level: "1..60"}}}).then(data=>console.log(data[0].data.slug))